User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: cruise control fault

  1. #1
    Regular Member
    Join Date
    Nov 2008
    Location
    glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default cruise control fault

    my cruise control on my vectra dont work at all ,its worked once since i got the car but once only i dont even get the green light on the dash when i try activating it any ideas pls

    52 plate 1.8 petrol
    model/ ellegence

  2. #2
    Full Member spennny's Avatar
    Join Date
    Jun 2008
    Location
    Blantyre
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by alexgrfc View Post
    my cruise control on my vectra dont work at all ,its worked once since i got the car but once only i dont even get the green light on the dash when i try activating it any ideas pls

    52 plate 1.8 petrol
    model/ ellegence

    Place your foot under the brake pedal and jerk it up, and also the clutch (one at a time ), maybe one or the other is not raising completely to the top, or could be a switch prob

    Had this issue 2 weeks ago but only did it once , so i did the above and been fine since

  3. #3
    Regular Member
    Join Date
    Sep 2007
    Location
    Thornton Dale
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Transit Custom

    Trim : Limited

    Engine : 125PS

    Year : 2013

    Default

    You can buy a spring for a fiver that goes under the clucth pedal that keeps the pedal at its highest point.

    As the clutch gets used over time, the spring weakens or snaps and the pedal drops which makes the switch for the cruise not work correctly.

    Takes less than 5 minutes to fit.

  4. #4
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Don't forget you need to have pressed the preak pedal once on your trip before it will work too
    Now I need a turbo to keep up!

  5. #5
    Regular Member John C S's Avatar
    Join Date
    May 2007
    Location
    Gangsta crossover on the drive? Check
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Big Sig View Post
    Don't forget you need to have pressed the preak pedal once on your trip before it will work too

    P is a long way from the B on the keyboard.


    PS When did you become a Guru??

  6. #6
    Regular Member steeb82's Avatar
    Join Date
    Nov 2008
    Location
    darlington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i have exactly the same car and have the same issue

  7. #7
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    The cause of this is a broken spring under the clutch pedal or which ever one it is. Its a known VX fault and there is a modified part which only takes a couple of minutes to fit and costs £6-7. Happened on my Vectra C 1.8 SRi when I had it.
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  8. #8
    Regular Member steeb82's Avatar
    Join Date
    Nov 2008
    Location
    darlington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    were can i get part and what needs to be done??

  9. #9
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    Quote Originally Posted by steeb82 View Post
    were can i get part and what needs to be done??

    I would try the dealer first, probably a Vauxhall one

    Talk to them nicely and they may even fit it for you for free, mine did!

    Have u checked for a broken spring?
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  10. #10
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by steeb82 View Post
    were can i get part and what needs to be done??
    One quick forum search:-

    http://www.vectra-c.com/forum/showthread.php?t=33621

    .

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cruise control fault, new stalk fix problem?
    By taffy bhoy in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 21st July 2013, 11:16
  2. Cruise Control Fault.
    By pattz123 in forum Bodywork & Interior
    Replies: 4
    Last Post: 7th February 2011, 00:24
  3. vectra c cruise control fault
    By hopkinson06 in forum General Chat
    Replies: 2
    Last Post: 31st January 2009, 14:42
  4. Cruise control fault?
    By jamesr in forum Engine & Drivetrain
    Replies: 29
    Last Post: 10th May 2008, 11:00
  5. manual control or cruise control.
    By johnm in forum Vectra C / Signum Car Chat
    Replies: 19
    Last Post: 6th February 2008, 14:20

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •