User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Damn Spanner Light Coming on

  1. #1
    Regular Member Dazfoz's Avatar
    Join Date
    Sep 2008
    Location
    Gloucester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Damn Spanner Light Coming on

    Hi guys,

    Hope you can help.

    A couple of weeks ago, my spanner light came on (Very cold morning if that helps), the light stayed on for about 2-3 mins, then went off. If i turn the engine off, and back on again, the light comes on at ignition set to on, but as soon as the engine fires up the light goes off.

    But, ince the engine is cold again, the light stays on for about 2-3 mins again....

    The light seems to stay on longer if the outside temp is lower.

    Thoughs?

  2. #2
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    See your profile says you've got a 1.9cdti.

    The spanner light will come on if you've got water in the diesel fuel filter (as well as other reasons). Have you checked to see if any water is present and needs draining out?

    If a fault code is stored, then the light will remain on until the engine is started. Might be worth getting the stored code read out to save on guesswork.

  3. #3
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check your oil level m8

  4. #4
    Regular Member Dazfoz's Avatar
    Join Date
    Sep 2008
    Location
    Gloucester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Will have a look, but would the light not act similar at every start if this was the case?

    Thanks

    Daz

  5. #5
    Regular Member
    Join Date
    May 2007
    Location
    southend on sea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi mate you might have a faulty glow plug, had a similar problem with my 54 1.9 cdti recently.
    When we had the cold nights recently the spanner light came on at start up and would stay on for a few minutes and then go off. If i started the car again while it was still warm no light.

    Put a fault code reader on it and it pointed at a problem with glow plug bank A . Had it replaced and no more spanner light.

  6. #6
    Regular Member Dazfoz's Avatar
    Join Date
    Sep 2008
    Location
    Gloucester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well....Got myself a U581 code reader, connected it up and it detected...Naff All...No codes stored, but the spanner light was still on!!

    Was reading all live data correct.

    So anyway, I clicked on clear fault codes, and hey presto the Spanner disappeared.

    So lets see in the morning if the spanner comes on when the engine is cold.

    Daz

  7. #7
    Regular Member Dazfoz's Avatar
    Join Date
    Sep 2008
    Location
    Gloucester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well, of to the stealers I guess.............Fired the oil burner up this morning, Spanner light on.

    I connected the reader up and still no code stored.

    Does anybody know if a U581 reads Glow Plug errors as Drew suggested?

  8. #8
    Regular Member
    Join Date
    Feb 2007
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The U581 can only read fault codes from the engine ECU. Any one of the other ECU's in the car could be logging a fault, but the U581 isn't able to read them.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Spanner light coming on and going into limp???
    By russ1969 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 20th August 2012, 22:29
  2. Damn spanner light again.
    By brotherkennyh in forum Engine & Drivetrain
    Replies: 9
    Last Post: 8th September 2011, 21:33
  3. damn eml light coming on
    By tomo41 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 11th June 2011, 21:47
  4. Spanner light coming on Vectra SRi 1.8 Y reg
    By coolesmudge in forum Engine & Drivetrain
    Replies: 6
    Last Post: 9th January 2009, 09:06
  5. Spanner over a car light keeps coming on
    By rollercoaster63 in forum Vectra C / Signum Troubleshooting
    Replies: 11
    Last Post: 28th January 2008, 20:29

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •