User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Loss of power

  1. #1
    Regular Member vectra-c1000's Avatar
    Join Date
    Mar 2008
    Location
    in a veccy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Loss of power

    Hi folks just a problem i have every now and theni am losing power seems like the turbo not working or cutting in had the computer pluged in and it seems to be the camshaft sensor went to stealers and they told me vectra 2.2 sri dti have not got a camshaft sensor any idears thanks.

  2. #2
    Regular Member joewin1975's Avatar
    Join Date
    Dec 2007
    Location
    merseyside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just an idea, but check your boost pipe. Mine split and i lost power to my turbo, a very common problem on the dti i believe................

  3. #3
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check the hose very carefully it's full length on top and underneath for any small split. Very common problem on that engine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. loss of power
    By STRETCH2009. in forum Engine & Drivetrain
    Replies: 6
    Last Post: 8th August 2012, 18:44
  3. Power loss HELP
    By dezzyb66 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 28th July 2012, 12:34
  4. 2L DTI '53 Loss of Power
    By BigTunz in forum Engine & Drivetrain
    Replies: 17
    Last Post: 3rd November 2011, 17:27
  5. loss of power
    By philly in forum Engine & Drivetrain
    Replies: 11
    Last Post: 11th May 2009, 07:21

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •