User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Help needed cdti 150 performance problems

  1. #1
    New Member
    Join Date
    Apr 2009
    Location
    Preston,lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vectra

    Trim : sri

    Engine : 150 cdti

    Year : 2006

    Mileage : 62000

    Angry Help needed cdti 150 performance problems

    Hello all, in the last few days my carís been having performance problems, imagine driving a large car with a small diesel engine thatís naturally aspirated.
    The car in question is my 2006 Vectra 1.9 cdti 150 thatís done 62000 miles.

    The symptoms: like someoneís nicked the turbo, tick over often lumpy but not always, when I pull away I can press the accelerator to the floor with very little happening, it feels worse than limp mode, until the rev counter gets to 3k, then it starts to pull but still not like it should. Thereís no smoke out the back and slightly down on mpg.

    Things I have considered and checked:-
    Turbo (itís still present)
    Fuel filter renewed.
    Throttle body cleaned.
    MAP sensor removed and cleaned.
    Vacuum and boost pipes, appear in good condition no splits and not perished or blocked.
    New inlet manifold, so I confident the swirl flaps are working.
    Egr valve cleaned and operation checked also fitted fiat type semi blanking gaskets both sides.

    No fault codes stored but the car with a spanner comes on and stays on until the engine starts (no problems starting).. Out of pure desperation I disconnected the battery and left it for half an hour, after reconnecting it I took it for a 2 mile drive all the symptoms had gone, the car was behaving how it should, happy thinking all was ok I turned it off and had a coffee. After an hour I returned to the car started it up and it was back to driving a large car with a small diesel engine thatís naturally aspirated.
    Iím at my wits endand cant work it out. Can anyone help me understand whatís going on please.
    Many thanks.

  2. #2
    Regular Member
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    your local to me so your welcome to pop it down to me

  3. #3
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Have money on it being EGR, blank it fully to test.

  4. #4
    Regular Member
    Join Date
    Dec 2010
    Location
    Cambridge
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VectraC CDTI 150

    Trim : Elite

    Engine : Z19DTH

    Year : 07

    Mileage : 175000

    Default

    A mate had same problem with his Zafira. After all it was the exelerator pedal. 130£ from VX and the problem gone.

  5. #5
    Regular Member Teapot's Avatar
    Join Date
    Mar 2010
    Location
    woodbridge, suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    203 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design+

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 101000

    Default

    Quote Originally Posted by paulvectrac View Post
    your local to me so your welcome to pop it down to me
    LOL, go in with a fault and only 50bhp, come out with a remap and 190bhp

  6. #6
    Regular Member
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    @littleteapot lmao you no it makes sense lmao hahah

  7. #7
    New Member
    Join Date
    Apr 2009
    Location
    Preston,lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vectra

    Trim : sri

    Engine : 150 cdti

    Year : 2006

    Mileage : 62000

    Default

    moneys tight, out of work at the moment so i will try to bodge some temp plates to blank egr as suggested by dan. how would it affect the MOT with no EGR ?
    Would it need a remap?

  8. #8
    Regular Member
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    if you completly blank it the eml light will come on then fail mot of you need it mappin out let me know

  9. #9
    Regular Member Teapot's Avatar
    Join Date
    Mar 2010
    Location
    woodbridge, suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    203 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design+

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 101000

    Default

    Quote Originally Posted by paulvectrac View Post
    if you completly blank it the eml light will come on then fail mot of you need it mappin out let me know


    Blanking the EGR without disabling in mapping will have no negative effects other than EML light on. In fact it will probably improve fuel economy a little. But to get the EML off the mapping must be edited.
    2006 Signum Design+ 1.9 CDTI and 2007 Signum Elite 2.8 V6 Turbo
    1.9 CDTI Diagnostics and tuning, remote remapping for distant members
    PM for more info.
    Remaps for Insignia 2.0 CDTI up to early 2012 *New* Remaps for 2.8 V6 Turbo

  10. #10
    New Member
    Join Date
    Apr 2009
    Location
    Preston,lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vectra

    Trim : sri

    Engine : 150 cdti

    Year : 2006

    Mileage : 62000

    Default

    Ok quick update removed egr and inspected, it was quite clean the semi blanking gaskets doing a good job.
    However I decided that if the egr was goosed I had nothing to loose by hooking it up to a 12v supply to see if the solenoid would function. It did, the valve opened with power and closed when the power was removed, all ok then it obviously works just fine. So I separated the valve from the solenoid and left it in some petrol, might as well clean what bit of crud that was, after a good scrub I reassembled it, back on the car it went.
    I didn’t bother blanking it off totally I used the same fiat type semi blanking gaskets but didn’t plug in the electrics, my reasoning for this was to simulate total blanking just for elimination purposes.
    Started up (eml on) drove off it seemed ok, but still a bit slow on setting off then got more torque about 2k on the rev counter and carried on pulling throughout the gears, soon hit triple figures (private road) and didn’t even get out of 4th and had to back off (ran out of road) so slightly better than yesterday then.
    Stopped and plugged in the egr, set off again (no eml) next to no difference In performance, if I am correct this means that the egr is ok and working as it should,
    So mid range and top end seem ok but from a stand still low end grunt is still poor like its being bogged down.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dissapointed in my cdti performance
    By jonny22 in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 21st May 2012, 17:17
  2. VXR Performance and Handling Problems
    By VXR_DV in forum The 'Off Topic' room
    Replies: 7
    Last Post: 16th March 2011, 16:43
  3. Help needed for Sick Signum CDTI with problems
    By sjmiow61 in forum Vectra C / Signum Car Chat
    Replies: 21
    Last Post: 29th April 2010, 18:31
  4. 1.9 CDTi (150) sluggish performance
    By nick_s in forum Engine & Drivetrain
    Replies: 17
    Last Post: 7th December 2009, 18:52
  5. Anybody had any problems with JAM performance
    By Robward27 in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 27th March 2009, 15:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •