User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Spanner Light

  1. #1
    Regular Member
    Join Date
    Jan 2012
    Location
    suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Spanner Light

    Hi all
    Vectra 1.9 cdi 150 2004 spanner light on no stored codes,rev to 4000 spanner light goes out and then comes back on after 30 seconds.
    Any ideas? Shaun.

  2. #2
    Regular Member
    Join Date
    Feb 2012
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SIGNUM 1.9 CDTI ELITE

    Trim : ALL OPTIONS ELITE

    Engine : 1.9 CDTI 150

    Year : 2005

    Mileage : 140,000

    Default

    Have you tried disconnecting the egr valve and going for a run?

  3. #3
    Regular Member
    Join Date
    Jan 2012
    Location
    suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by bladeage1 View Post
    Have you tried disconnecting the egr valve and going for a run?
    Hi I have disconnected egr and went on run, spanner light on all the time. I expected the eml to come on after disconnecting the egr but it didnít.Shaun.

  4. #4
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    When you say no codes are stored, what are you using to read the codes? As some cheap hand-held code readers will only read certain engine codes

  5. #5
    Regular Member
    Join Date
    Jan 2012
    Location
    suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by tony-1977 View Post
    When you say no codes are stored, what are you using to read the codes? As some cheap hand-held code readers will only read certain engine codes
    Hi It has been tested with cheap elm 327 and a snap on codereader both turn the spanner light of when reset is hit but the spanner comes on 3 seconds later.
    Think it is egr valve as had eml light on and got code p0400a few weeks ago, when eml on no spanner light as soon as reset and turn off eml spanner light back on. Also no eml with egr unplugged. Also tried brake and accelerator trick still no codes Shaun
    Last edited by shaun.b; 21st March 2013 at 16:49.

  6. #6
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    P0400 is EGR related. Check it is plugged in securely. I fell for this once, pushed the plug on and all was fine

    Might be worth removing and cleaning the EGR, as per the How To on here.

  7. #7
    Regular Member
    Join Date
    Jan 2012
    Location
    suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by tony-1977 View Post
    P0400 is EGR related. Check it is plugged in securely. I fell for this once, pushed the plug on and all was fine

    Might be worth removing and cleaning the EGR, as per the How To on here.
    Hi Thanks for replies can you remember what lights came up with loose egr plug spanner, eml or both, Shaun

  8. #8
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    The spanner light came on when the plug was loose.

    If you blank the EGR but keep it plugged in, the spanner light will come on, followed by the eml light.

  9. #9
    Regular Member
    Join Date
    Jan 2012
    Location
    suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by tony-1977 View Post
    The spanner light came on when the plug was loose.

    If you blank the EGR but keep it plugged in, the spanner light will come on, followed by the eml light.
    Hi but should the eml come on if egr unplugged?

  10. #10
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Quote Originally Posted by shaun.b View Post
    Hi but should the eml come on if egr unplugged?
    Mine didn't. Just the spanner light.

    When I blanked of fthe EGR and left it plugged in, the eml light came on.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Problems with Air bag light, ABS, Anti Skid & Spanner light
    By WeDesign in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th December 2012, 21:23
  3. Should I Have A Spanner Light aswell as an Engine Light on My Signum?
    By StreetDragster in forum Engine & Drivetrain
    Replies: 16
    Last Post: 18th August 2012, 11:57
  4. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  5. spanner light reset emission light now on HELP!
    By johnny boy67 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 7th December 2009, 12:07

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •