User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Replaced Thermostat now showing error P0597.

  1. #1
    Regular Member
    Join Date
    Sep 2007
    Location
    Aberdeen
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Replaced Thermostat now showing error P0597.

    Hi Folks,

    I have a 1.8VVT 06 veccy, recently changed the thermostat due to low engine temp and low mpg. Flushed and replaced the coolent at the same time. For about 3month the car worked fine, engine temp was up to 90, and mpg had improved.

    Last week a yellow warning light, car with spanner appeared. I read the fault code using the accelerator and brake method and go two codes one relating to the the cruise control (which works fine) and the other P0957 refers to the thermostat open or short circuit.

    Thermostat seems to be working fine, the engine temp climbs to 90 and remains at 90. I have disconected the battery for 30min but the light remains on and the same codes are shown.

    Called the local VX garage and they want £106 to diagnose the problem.

    Any advice?

  2. #2
    Regular Member Dippy-Vx-line Red's Avatar
    Join Date
    Mar 2008
    Location
    Earlston (Scottish Borders)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I did a check on the code reader (code P0957) I have and it comes up with.. "Auto Shift Manual Mode Circuit Low"...HTH

  3. #3
    Regular Member
    Join Date
    Sep 2007
    Location
    Aberdeen
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Interesting dippy27, I did an net search on the code and found ;
    http://www.google.co.uk/url?sa=t&rct...1oQ_OtQD-NCUQg
    hence why i though thermostat issues.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replaced Thermostat - some advice please.
    By colreid in forum Engine & Drivetrain
    Replies: 13
    Last Post: 22nd April 2012, 19:18
  2. Voltage Showing On the BD
    By Si-SRI in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 6th November 2010, 18:58
  3. Instant MPG showing 9?!?!
    By Morzy in forum Engine & Drivetrain
    Replies: 15
    Last Post: 14th September 2010, 21:03
  4. @rsehole showing off !
    By FIL 4822 in forum Vectra C / Signum Car Chat
    Replies: 43
    Last Post: 10th February 2008, 19:55

Visitors found this page by searching for:

vectra fault code p0597

vectra fault code 0597

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •