User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Vectra c 52 no reverse lights any help appreciated

  1. #1
    Regular Member
    Join Date
    Feb 2013
    Location
    Northants
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c

    Trim : Ls

    Engine : 1.8

    Year : 52

    Default Vectra c 52 no reverse lights any help appreciated

    Hi all
    ive just picked up a vectra c on 52 plate with a few probs cheep while I'm between jobs.
    The first job is no reverse lights. So far....

    bulbs ok. Bulb housing wiring and connectors ok to boot fuse box.
    Reverse switch ok. I have 12v at the switch on white/black and when in reverse I get 12v out on the brown.

    im assuming the brown continues through various connectors to the boot and plugs into the fuse box. I can only see one brown wire connected into the fuse box and it has no voltage so I'm guessing there is a break or bad connection somewhere.

    Can anyone confirm which wire plugs into the fuse box from the reverse switch? And also the journey it takes and does it stay the same colour?

    Many thanks
    barks

  2. #2
    Regular Member richy1974's Avatar
    Join Date
    Jun 2012
    Location
    leek
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    How do you know reverse switch is ok. I got a brand new one for a golf a few months back after checking various things found out the new switch was faulty

  3. #3
    Regular Member
    Join Date
    Feb 2013
    Location
    Northants
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c

    Trim : Ls

    Engine : 1.8

    Year : 52

    Default

    Quote Originally Posted by richy1974 View Post
    How do you know reverse switch is ok. I got a brand new one for a golf a few months back after checking various things found out the new switch was faulty
    hi.
    I have done a continuity test on the switch and its fine. As stated giving me 12v on brown when in reverse.

    Im going to have to unplug all multi plugs and trace it tomorrow.

  4. #4
    Regular Member
    Join Date
    Sep 2011
    Location
    norwich,norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Haynes manual show white/black wire comes from engine bay control unit,giving you 12 volts on switch, and brown wire goes to chassis,so disconnect brown wire and continuity test to chassis.if okay then,you will need to check rear fuse box control unit,where again white and black should have 12 volts on it when in reverse.
    You say you have 12 volts on brown how are you testing it and is it relative to chassis m8

  5. #5
    Regular Member
    Join Date
    Feb 2013
    Location
    Northants
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c

    Trim : Ls

    Engine : 1.8

    Year : 52

    Default

    Quote Originally Posted by maud2450 View Post
    Haynes manual show white/black wire comes from engine bay control unit,giving you 12 volts on switch, and brown wire goes to chassis,so disconnect brown wire and continuity test to chassis.if okay then,you will need to check rear fuse box control unit,where again white and black should have 12 volts on it when in reverse.
    You say you have 12 volts on brown how are you testing it and is it relative to chassis m8
    Thanks maud
    when in reverse I have 12v between chassis and brown wire at switch so from what you have stated there must be an earth fault on the brown. Ie it should be connected to chassis.
    Am I right then in saying the engine control unit applies 12v to the switch and waits until the 12v is grounded then communicates with the rear boot fuse box to apply 12v to the reverse lights ?
    cheers
    barks

  6. #6
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Sounds like open circuit on brown wire mate

  7. #7
    Regular Member
    Join Date
    Feb 2013
    Location
    Northants
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c

    Trim : Ls

    Engine : 1.8

    Year : 52

    Default

    Quote Originally Posted by Critch View Post
    Sounds like open circuit on brown wire mate
    Yes mate.
    I would never of expected a 52 plate vectra to have a data communication between front and back. Makes sense less cables ect but on a 52 plate I'm amazed. I also learned today that the rain sensors close the windows if it starts raining. Lol
    to test if I short the white/black to ground at switch the reverse lights should come on. The switch dosent have diode or resistance so 12v must be transistorised. .

    cheers
    barks

  8. #8
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    The ecu will put 12v and watch on line waiting for it too be pulled to ground.

    use a test light on white wire and see.

    test light is slightly safer than just using a jumper wire.

  9. #9
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Should have also said that it will either power or ground the cicircuit if its ecu controlled

    from here I can't say what it is as I don't have diagram in front of me.

  10. #10
    Regular Member
    Join Date
    Feb 2013
    Location
    Northants
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c

    Trim : Ls

    Engine : 1.8

    Year : 52

    Default

    Quote Originally Posted by Critch View Post
    Should have also said that it will either power or ground the cicircuit if its ecu controlled

    from here I can't say what it is as I don't have diagram in front of me.
    Thanks critch
    i tried to find a wiring diagram but no joy.
    Cheers again

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Reverse lights issue
    By prokie in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 23rd December 2011, 10:42
  2. tinted the reverse lights out!!!!!!!
    By j1 wyx in forum Vectra C / Signum Car Chat
    Replies: 24
    Last Post: 24th February 2011, 19:54
  3. no reverse lights
    By dean79 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 17th May 2010, 21:39
  4. help no reverse lights!!
    By monty2000 in forum Electrical & ICE (including SatNav)
    Replies: 8
    Last Post: 5th April 2010, 21:59
  5. reverse lights?
    By big rich in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 12th December 2008, 02:01

Visitors found this page by searching for:

vectra c reverse lights not working

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •