User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Spanner light

  1. #1
    Regular Member nokiaman1978's Avatar
    Join Date
    Sep 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Spanner light

    Started car this morning after getting my tattoo touched up, tried the wipers and still no water, drove off and noticed spanner light on dash so took the car for a spirited run and it drove better than ever, got home switched of and then started again and no light my car is due to get booked in for stuck open thermostat ast temp never goes above the first marker and mostly sits at zero in cold weather, could this be the cause of the light being on, but surely it would have stayed on.

  2. #2
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    No - spanner light wont come on with a stat issue.

    Was the car cold when you started it and then got the spanner light.. I take it you have a CDTI.

    Suggest its a glow plug fault if it was cold, and then went on restart when the car is warm. Pretty common TBH.

    You will have a stored code in the ECU that will tell you.

  3. #3
    Regular Member nokiaman1978's Avatar
    Join Date
    Sep 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    car was driven for about 10 miles, but didnt heat up because of thermostat, sat for an hour and then restarted, thats when light came on, there has been days it's been -17 and had no light on startup, yep it's a cdti, will keep an eye on it.

  4. #4
    Regular Member nokiaman1978's Avatar
    Join Date
    Sep 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what lights should stay on when ignition turned to power, my spanner and engine managment light stay on till i start the car, im sure this is normal, getting a bit paranoid

  5. #5
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    Emmisions will stay until engine is running.

    The Spanner will come on with the ignition IF you have a stored fault code (which you do). Normally you will not see the spanner at all.

    If it goes out when running (the spanner) it means the fault is no longer present.

    HTH

  6. #6
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  7. #7
    Regular Member nokiaman1978's Avatar
    Join Date
    Sep 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    will the fault clear if not present after x amount of restarts

  8. #8
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If the car and spanner comes on with the ignition and then goes off after a couple of seconds as per what the owners manual says its nothing to worry about. Yes it will clear after a while if it does'nt re-occur.

    If the car and spanner comes on whilst driving or comes on and stays on then time to get it looked at.

  9. #9
    Regular Member
    Join Date
    Nov 2010
    Location
    St.Ives
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sorry to hijack but is the thermostat thing a common problem as i noticed mine hardly moved during the really cold weather and now it goes to just below the first notch.

  10. #10
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    Quote Originally Posted by nokiaman1978 View Post
    will the fault clear if not present after x amount of restarts
    If that same eror doesnt come back then yes.

    TBH Id want it read first so I know where there may be a weak area..

    A

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Problems with Air bag light, ABS, Anti Skid & Spanner light
    By WeDesign in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th December 2012, 21:23
  3. Should I Have A Spanner Light aswell as an Engine Light on My Signum?
    By StreetDragster in forum Engine & Drivetrain
    Replies: 16
    Last Post: 18th August 2012, 11:57
  4. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  5. spanner light then engine management light
    By learoy69 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 12th March 2010, 20:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •