User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: why wont spanner light go off

  1. #1
    Regular Member
    Join Date
    Nov 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default why wont spanner light go off

    On my cdti 150, the spanner light is always on at engine start up, stays on then after exactly 3 mins goes off and wont come back on untill engines off and i restart the engine again,

    Any help would be gratefull
    Last edited by bigmac; 8th December 2010 at 22:49. Reason: Swear filter

  2. #2
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Because there is a problem.

    And it sounds like a glow plug issue.

  3. #3
    Regular Member
    Join Date
    Nov 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    would a glow plug issue cause any change in the drive?

    As the car itself is driving a dream, i cant physically feel any change at all

  4. #4
    Regular Member
    Join Date
    Jan 2010
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had this problem. Read fault codes and pointed to glow plugs. Changed them, problem gone.

  5. #5
    Regular Member bangty 1's Avatar
    Join Date
    Sep 2010
    Location
    in a box
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by japeye86 View Post
    would a glow plug issue cause any change in the drive?

    As the car itself is driving a dream, i cant physically feel any change at all
    nope only used on start up

  6. #6
    Regular Member
    Join Date
    Nov 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks, how much is it to change a glow plug,and is it easy, im pretty basic when it comes to mechanics

  7. #7
    Regular Member Jow20's Avatar
    Join Date
    Sep 2010
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Av u reset it after service interval indicator? Thats what i had to do... Every year/20k miles it comes on as you say, jus needs resetin, i googled it and it told me how to do it, gotta hold button in and turn car on n off or summet

  8. #8
    Regular Member
    Join Date
    Nov 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    oh, i may give that a go, but its not due a service for 3000 miles yet

  9. #9
    Regular Member Jow20's Avatar
    Join Date
    Sep 2010
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Doesnt matter unless ur service book is perfect to the day! Ur ecu thinks it needs services every year since date of purchase/xxxx miles, mine always comes on in august evey year but i dont service until march! Its jus the way it naturally falls out of sync, id defo try this before anyting, i think u hold ur speedo reset button while car is off for 3 secs till it bleeps then turn car on and off. (i think) keep updated how u get on

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. spanner light and wont idle
    By wbm156 in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 31st March 2011, 16:26
  3. flashing spanner and wont start
    By jofenan in forum Engine & Drivetrain
    Replies: 9
    Last Post: 3rd February 2011, 13:52
  4. Spanner on dash wont start please help
    By alshel in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 5th November 2009, 02:25
  5. Parking light check bulb light on and wont go off
    By rollercoaster63 in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 16th November 2008, 12:03

Visitors found this page by searching for:

what would cause glow plug to flash on 2008 1.9cdti vectra

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •