User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: z18xer fitted new pullies and solenoids still rattling?

  1. #1
    New Member
    Join Date
    Jun 2020
    Location
    wrexham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Exclusiv

    Engine : z18xer

    Year : 2006

    Default z18xer fitted new pullies and solenoids still rattling?

    Hi guys so I recently fitted brand new GM cam phaser pullies both intake and exhaust and also fitted 2 new solenoids but I am still getting the rattle on startup which goes away in like 3 seconds. You can still here the intake pulley very faintly rattling once it's warmed up.

    Does anyone know if this is normal because am really not sure what to do now as I have replaced every component from the vvt system and I am 100 percent sure its still coming from the intake pulley because if you pull the plug to the intake solenoid when the engine is running it gets louder so its decently coming from the intake pully.

    I have also recently changed oil and filter and I am using dexous 2 0w40 engine oil.

  2. #2
    Regular Member
    Join Date
    Nov 2013
    Location
    suffolk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra 2007

    Trim : sri

    Engine : z18xer

    Year : 2007

    Default

    I've found the rattle reduces, if you give it a few seconds - following ignition on, until you engage the starter motor - say the time it takes to put your seat belt on.

  3. #3
    Regular Member
    Join Date
    Dec 2010
    Location
    London
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Hyundai Ioniq Hybrid

    Trim : Premium SE

    Engine : 1.6 with 32KW motor


    Default

    I looked into this when i had mine and i think it is caused by wear in a non return valve which allows oil to drain overnight.


    https://vauxhall.7zap.com/en/car/z02/e/4/30-0/

    Number 8
    Last edited by troutybrown; 4th August 2020 at 11:24.

  4. #4
    Regular Member nismo128's Avatar
    Join Date
    Dec 2008
    Location
    east sussex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : XP SRI

    Engine : 1.8vvt

    Year : 58

    Mileage : 67

    Default

    I have new vvt pulleys and new solenoids and belt etc and mine was doing what yours is doing diesel type tick for about 2 seconds on start when motor is cold,I switched out the oil from from Genuine GM Dexos2 5/30 to FUCHS Titan GM Dexos2 5/30 and a Halfords/crossland oil filter this time choosing a filter without a non return valve and the noise is gone,hope that helps you.

  5. #5
    Regular Member
    Join Date
    Jan 2008
    Location
    ...........
    Post Thanks / Like
    Mentioned
    115 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : .....

    Trim : .....

    Engine : .....

    Year : .....

    Mileage : .......

    Default

    As above, I've fitted lots of these.
    You won't get rid of the "tick" until a new non return valve has been fitted.

    Did you remember to remove the small filters from the new phasers???

  6. #6
    New Member
    Join Date
    May 2019
    Location
    South Lanarkshire
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Exclusive

    Engine : Z18XER

    Year : 2007

    Default

    A lot of useful info in this thread. I bought a timing kit 3 years ago to do the belt and pulleys for the 100k and/or 10 years but before I did I developed the diesel racket. I told my daughter just to drive it we'll take from there. I learned a bit about the system and after she returned the car to me as excess to requirements I thought I'd start by checking the solenoids as the rattle was intermittent. A daisy fault. Days it did it and days it didn't .I decided to check the inlet solenoid. You know. The one that just slides out and in easily. WELL it didn't go like Ed China or every other Haynes Manual. IE Now pull sprocket from shaft. Boy did it not want to move. With a lot of brute force and ignorance I got it out deforming the bracket on the solenoid in the process. I had seen somewhere that the OFFICAL VX resolve was to remove the filters. So I did this and tried to get it back in. I thought that I had but a trail of oil said otherwise. I removed it and this time it slotted right into position. With hindsight I should have checked the channel for debris. So I ordered 2 new solenoids. When they arrived I replaced the old with the new but this made no difference. As the rattle came and went I suspected the oil pressure may be varying so I purchased an oil pressure gauge with the intention of removing the oil pressure switch and substituting the gauge and noting any variation. But unlike the Astra where the oil pressure switch is right under your nose I 've still to find the switch.
    Troutybrown's link shows the oil pump behind the rear timing belt cover and am now wondering whether to change oil pump when doing the belt and variators.
    I'll fit oil pressure gauge first as if its OK there's no point in changing it.


    Following this thread with great interest.

  7. #7
    New Member
    Join Date
    May 2019
    Location
    South Lanarkshire
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Exclusive

    Engine : Z18XER

    Year : 2007

    Default

    This makes good reading
    https://www.vectra-c.com/forum/1843029

    I guess I was not the only one with the difficulty getting the inlet solenoid out


    https://www.vectra-c.com/forum/showt...=1#post1843029
    Last edited by Pomeo; 7th August 2020 at 22:59. Reason: linking

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. INA Camshaft Solenoids
    By Merlin51 in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 12th August 2018, 10:20
  2. cam phaser solenoids
    By Craig711 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 21st October 2014, 19:29
  3. Cam Phaser Solenoids VVT
    By Jebus in forum Engine & Drivetrain
    Replies: 4
    Last Post: 25th February 2014, 21:42
  4. Z18XER (1.8VVT) Cam Solenoids
    By VVT-i-MATT in forum Engine & Drivetrain
    Replies: 42
    Last Post: 2nd February 2013, 10:35
  5. VVt Cam Phaser Solenoids
    By Ben50n in forum Engine & Drivetrain
    Replies: 30
    Last Post: 10th September 2012, 07:48

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •