User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Spanner light maybe fixed what you think?

  1. #1
    Regular Member
    Join Date
    Nov 2009
    Location
    telford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Spanner light maybe fixed what you think?

    I took my signum back to the garage where i brought it from due to spanner light coming on. They have read the codes and its come up with a fault code. They say its the Throttle sensor valve? what do you guys think of this? hopefully this might be the end of the spanner light.

  2. #2
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What were the symptoms? My mate had this on his old car, but didnt actually do anything to the performance of the car!


    Bye bye Vec B
    - Hello Siggy!

  3. #3
    Regular Member
    Join Date
    Nov 2009
    Location
    telford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    basically i can drive it around for 5 days not a problem, the i can start it up and the spanner light coming on then the cut cuts out, i try to restart but still the same. if i leave it for 10 to 20 minutes then try it its ok again.

  4. #4
    Regular Member elkesprint's Avatar
    Join Date
    Sep 2008
    Location
    York
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Was it a main dealer and did they charge for reading the codes?

  5. #5
    New Member
    Join Date
    Jan 2010
    Location
    suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    first of all what fuel are u using i had no end of trouble using tesco diesel cleaned throttle body out that helped then tried running it on shell no problem got short of diesel one day filled up at tesco got through half a tank guess what spanner light again been using shell now for about 3000 miles not come on once ???

  6. #6
    New Member
    Join Date
    Feb 2008
    Location
    Hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have had a very similar problem to this that I now understand. There are 2 vacuum solenoids at the front of the engine compartment near to the battery. One controls the throttle position and the other the swirl flaps. The swirl flaps change the way in which the air enters the cyliinders so you can ignore that, but the other controls the throttle position. Before the car starts the throttle is wide open and the vacuum solenoid allows vacuum through from the vaccum pump to the throttle actuator. Once started the vacuum builds up and the ECU has to send a signal through to the solenoid to stop the vacuum, otherwise it will shut off the flow of air to the engine and kill it. The signal through to the valve actually pulses to get the throttle in the correct position in accordance with a sensor on the butterfly but this is not necessary to be understood for your apparent problem. With your issue it appears that the throttle is being shut down by the vacuum and you could proove this by either disconnecting the connector from the solenoid or the vacuum pipe from the throttle actuator and then attempting to restart. No guarantees on the source of the problem, I suggest reading the fault codes but it could be the vacuum valve, the small exhaust filter being clogged (which is shared between the 2 solenoids) or it then starts getting expensive as it could be the throttle body or ECU. Suggest you check the little filter is not clogged by pulling it off and sucking through it first, then read the codes.

  7. #7
    New Member
    Join Date
    Dec 2009
    Location
    liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Afternoon people, been trying to sort out my 06 2.2sri direct Vectra with a similar problem, car/spanner light keeps coming on after about 30 mins driving, has cut out a couple of times now and engine seems to have gone into limp mode, using more petrol.
    Got a fault code reader and came back with fault code P1112, any ideas what it could be and how to fix it once and for all.
    Thanks.

  8. #8
    New Member
    Join Date
    Dec 2009
    Location
    liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    And now, all of a sudden, in the last arf an hour, fault code P0100 is also showing up, cars ey, what a pain.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Problems with Air bag light, ABS, Anti Skid & Spanner light
    By WeDesign in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th December 2012, 21:23
  3. Should I Have A Spanner Light aswell as an Engine Light on My Signum?
    By StreetDragster in forum Engine & Drivetrain
    Replies: 16
    Last Post: 18th August 2012, 11:57
  4. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  5. fixed my airbag light today
    By glynn in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 30th August 2008, 21:14

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •