User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Dash Light Problem Vectra Facelift

  1. #1
    New Member
    Join Date
    Jan 2010
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry Dash Light Problem Vectra Facelift

    Hi Folks
    Have a problem which has occurred for the second time in ownership (2 years) however first time corrected itself this time has not.

    The Problem is the lights around the speedo are all out except the boot open light stays on, the speedo will not work, the rev counter petrol gauge temp gauge all do not work either, is this isuue minor (fuse or something more serious?)

    any thoughts ideas would be appreciated.

    Thanks in advance

  2. #2
    Regular Member kman247's Avatar
    Join Date
    Nov 2008
    Location
    milton keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by holden77 View Post
    Hi Folks
    Have a problem which has occurred for the second time in ownership (2 years) however first time corrected itself this time has not.

    The Problem is the lights around the speedo are all out except the boot open light stays on, the speedo will not work, the rev counter petrol gauge temp gauge all do not work either, is this isuue minor (fuse or something more serious?)

    any thoughts ideas would be appreciated.

    Thanks in advance
    Have you tried a bit of contact cleaner /wd40 on the connector on the back of the clocks? To remove dash pull off both dash trims , then the 2 torx screws hold the clocks in. make sure the steering wheel is fully towards you and down (this makes it easier to take the clocks out)

  3. #3
    Regular Member
    Join Date
    Mar 2007
    Location
    South wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by holden77 View Post
    Hi Folks
    Have a problem which has occurred for the second time in ownership (2 years) however first time corrected itself this time has not.

    The Problem is the lights around the speedo are all out except the boot open light stays on, the speedo will not work, the rev counter petrol gauge temp gauge all do not work either, is this isuue minor (fuse or something more serious?)

    any thoughts ideas would be appreciated.

    Thanks in advance
    Have you had any luck fixing this? My car is doing the same as of tonight

  4. #4
    Regular Member
    Join Date
    Jan 2009
    Location
    North of Watford Gap
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This happened to me last year for no apparent reason. My local Vx dealer advised trying a battery disconnect to reset the electrics. They would investigate more deeply if need be but as the failure was not associated with any other event they thought it would be worth trying. It did the trick and I have had no repetition since.
    I lost the data in the BC and I needed to reset the one shot for the electric windows but apart from that it was a simple fix. I have seen several threads on here with advice on resetting the windows if you don't have a manual.
    Hope this helps

    PG

  5. #5
    Regular Member Happy Dave's Avatar
    Join Date
    Apr 2007
    Location
    Nr Blackpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mine did this about a month ago, all i did was pull the fuse in the passenger fuse box (blue, #17 i think) and it worked again instantly

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. vectra vxr ,dash problem
    By allyp in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 10th January 2013, 19:37
  2. spanner lights on the dash of my vectra c facelift 1.9 cdti 120
    By danielle7906 in forum Troubleshooting
    Replies: 4
    Last Post: 16th June 2012, 18:10
  3. Vectra C FaceLift Light Adjuster Problem
    By Elahi_786 in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 15th September 2011, 03:02
  4. Vectra 2006 dash problem
    By scottg1123 in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 22nd March 2011, 14:52
  5. Dash Light Problem After Headunit Install
    By JACKALG1 in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 13th May 2007, 09:34

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •