User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Central display/steering wheel buttons

  1. #1
    Regular Member
    Join Date
    Nov 2007
    Location
    antrim
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Central display/steering wheel buttons

    Recently my battery died after I left my lights on. A mate got me going
    using jump leads. However after getting the motor going I've noticed the
    central dash display is now blank and the buttons for the radio/cd on the steering wheel no longer work.

    I wonder is it a fuse somewhere or I have I done more serious damage ? The radio/cd still works with the buttons on the unit. If it is which fuse(s) might it be and where do I find them and is its possible the bulb on the central display has blown as well ?

    Sorry this might sound a bit of a simple question but I'm truly green when it comes to cars. BTW its a 2003 vectra 2.2ls. Radio/cd is type cdr2005

    Many thanks in advance.

  2. #2
    Regular Member Ademusic's Avatar
    Join Date
    Dec 2009
    Location
    Dunstable
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If it's a fuse, then check the fuse box on the passenger side of the dash. Open the front passenger door, and on the side of the dash, there is a panel with an airbag sticker on it. Remove this panel by pulling hard on it (will take a bit of strength as it is tight), and you'll find the fuse box behind this panel. I would check all the fuses, but mainly the following:
    F1 - 20A - Infotainment system, dvd
    F17 - 15A - Instrument, info display
    F22 - 30A - Cigar lighter, dvd
    F26 - 7.5A - Instruments, info display

    Remember though, if you remove any fuses for the radio etc, you will need to enter the radio code as it will probably reset your radio. So please remember this before removing any fuses and make sure your have the 4 digit code for your radio!
    The tid (triple info display) is illuminated by 3 bulbs, so would be very surprised if all 3 blew at once. If it's a fuse that has gone, usually something else won't work as it's on the same circuit. Have you tried the horn / hazards / lights etc. Does everything else work ok? Try the fuses as above first and see if that sorts it out for you. Hope this helps!!
    Last edited by Ademusic; 3rd January 2010 at 11:15.

  3. #3
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Try fuse 12 also...

  4. #4
    Regular Member
    Join Date
    Nov 2007
    Location
    antrim
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Many thanks for the replies guys. I tried all of the fuses inc. no 12 but all appear intact. What I'll do now is try all of the fuses in the passenger box to see if maybe it's some other one. If not I don't know what else it might be. Would rather get to the bottom of it rather than having to go to Vauxhall and pay two fortunes ! Anyone any other ideas maybe on what might be causing it ?

  5. #5
    Regular Member
    Join Date
    Nov 2007
    Location
    antrim
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    After checking the fuses - hey presto when I switched on the ignition the display was working again. Must have been a bad connection somewhere. Display came up with the word "safe" - on checking the manual that means it just needed the code. I put that in and everything including the steering wheel buttons for the radio are now working.

    Many thanks to the posters above once again. Cheers !

  6. #6
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Just to clarify,
    I believe the fuses you were asked to check were indeed those in the passenger box (passenger side end of the dash-board).

    Which ones did you check initially, those on the left (passenger) side of the boot or those under the bonnet?

    Fuse 12 is for the BCM and is usually affected when an overload or a power-surge (such as a jump start) occurs.
    The bcm affects the supply to the display, especially light and can-bus information (links to/from other modules including the CIM, which provides inputs from the steering wheel controls for the radio)

    Those suggested by Ademusic affect the direct supply of current to the head-unit and display.
    Depending on how old your car is (approx 6 yrs in your case), the fuse links may have deteriorated, hence the temporary loss of power.
    Just to be on the safe side, ensure you keep a good clean spare for each value (colour) of mini blade fuse! - Just in case.

  7. #7
    Regular Member Ademusic's Avatar
    Join Date
    Dec 2009
    Location
    Dunstable
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Nice one, glad you got it sorted. New Robsey would know a bit more about it than me! Well done

  8. #8
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Just checked my TIS wiring diagrams / pin-outs, and they say that Fuse FI10 is the one that provides power to the CIM itself.
    FI = Fuse for Instrument Panel..that is the one on the end of the dash as discussed.

    If in doubt just check them all...as long as you've got the radio pass (on pre October 2004 cars)...then you cannot do any harm to anything on the car...at worst you'll need to reset the time on the clock!!

    I wouldn't say I'm more knowledgeable, it's down to having More Luck than Judgement.
    A decent set of wiring diagrams are always priceless for finding power related faults.

  9. #9
    Regular Member Ademusic's Avatar
    Join Date
    Dec 2009
    Location
    Dunstable
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Actually Robsey, while you're here, I hope you don't me picking your brains, but on my '06 vectra, I've got the CD70 unit...on my car pass it has a radio code, If I was to remove the unit, would I need to enter the code when re-installing it, or is it programmed to the CID or car etc..Just wanted to ask in case the radio code wasn't correct to the car ie: if the headunit etc has been replaced at some point. Thanks!

  10. #10
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    If the radio (CD70) is working fine with the current display, then they are paired to each other.

    Pulling the power via the battery,fuse or by removing either screen or head unit will not cause you any problems.

    When you refit the screen, head-unit, battery or a fuse, then the radio code does NOT need to be entered...only on radios pre october 2004( NCDC or CCR or NCDR etc).

    Although Vauxhall call them volatile memories, once coded the screen or radio (CC20, CD30, CDC40, CD50, CD70), do not ever have to have the codes re-entered again.
    Unless you want to divorce them from the car that is.
    Or you want to program a change to the BC function or software on any unit other than the CD70.

    If the radios and screen are paired, but not to each other, then the screen will have a permanent display saying SAFE.

    If the screen and/or radio are divorced, then the screen will "flash" SAFE every 5 or so seconds with an audible ping each time it flashes on the screen.

    Incidentally, if you go off from the main screen, then the SAFE message tends to stop flashing and pinging. ie CD track or radio station page, Navi Page or BC page as fitted.
    Last edited by Robsey; 7th January 2010 at 17:19. Reason: adding extra info.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Steering wheel buttons
    By Dedney in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 20th August 2012, 14:26
  2. Steering Wheel Buttons
    By liam8282 in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 20th March 2011, 10:10
  3. Steering Wheel Buttons
    By wotsthestory in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 2nd January 2010, 00:35
  4. steering wheel buttons
    By Big Knox in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 4th November 2009, 15:04
  5. steering wheel buttons
    By SRimonkey in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 20th April 2009, 00:26

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •