User Tag List

Thanks Thanks:  1
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Help Please. Vectra 1.9cdti 150bhp

  1. #1
    Regular Member
    Join Date
    Jul 2009
    Location
    N. Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Help Please. Vectra 1.9cdti 150bhp

    OK guys been having some awful problems with my 05 Vectra 1.9cdti 150bhp for a few months now. Had the EGR valve replaced by the dealers in July but over the past few weeks the car has been losing power all the time.

    Brought it to a mechanic, who was useless, and he said I needed 2 maybe 3 injectors replaced. Replaced 3 injectors (£80each) but made no difference at all. Took it to a different mechanic who then put my 3 original injectors in and the car was just the same. £240 down the pan already. Started to read on here and alot of people were having similar problems. My swirl valve was just lying there so done the £1 fix on it 2 days ago and so far its still in place. I've also cleaned the boost sensor which was really bad. Today i changed the injector wiring on the 3rd injector and still no difference. The spanner is still appearing and putting the car into limp mode and the engine management light is coming on. I took it to a gut who does diagnostics and the following 2 codes appeared which werent there when i had it checked last week. P0234 and P1109.

    I think i'm looking at a new inlet manifold?? Any further suggestions before I give in and take it to the Vx dealers???

    cheers,
    Colin

  2. Thanks Lazarus85 thanked for this post
  3. #2
    Regular Member parsco's Avatar
    Join Date
    Sep 2008
    Location
    Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hello mate,

    Sorry but that is exactly what the problem is, you need a new inlet manifold (this will include the actuator which may be the part that is broke).

    On another note, avoid Vauxhall if you can, try and find a good local garage to do it for you instead, otherwise you'll be paying out the nose .

    Good luck with it all mate, I know how it feels I've been there too

  4. #3
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    Hi P0234 is turbocharger boost.
    Sounds like the rubber hose to the turbo is split, pipe costs about £18 from Vx. Is quite a common fault.

  5. #4
    Regular Member
    Join Date
    Aug 2009
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i read you only replaced 3 injectors, then put the 3 originals back. so is there 1 (one ) thats not been touched ? could this be the problem one ?

  6. #5
    Regular Member
    Join Date
    Jul 2009
    Location
    N. Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the turbo does whistle abit and is noticeable when the bonnet is opened. Do you have a part number for the pipe by any chance? I think I will need the inlet manifold but trying to avoid it if i can and trade this car in. Seriously annoying my head at the min, lol.

  7. #6
    Regular Member
    Join Date
    Jul 2009
    Location
    N. Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by parsco View Post
    Hello mate,

    Sorry but that is exactly what the problem is, you need a new inlet manifold (this will include the actuator which may be the part that is broke).

    On another note, avoid Vauxhall if you can, try and find a good local garage to do it for you instead, otherwise you'll be paying out the nose .

    Good luck with it all mate, I know how it feels I've been there too
    Do I need to go through Vx to get the parts or can i souurce them myself?

    cheers for the input

  8. #7
    Regular Member
    Join Date
    Jul 2009
    Location
    N. Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by cranny 27 View Post
    i read you only replaced 3 injectors, then put the 3 originals back. so is there 1 (one ) thats not been touched ? could this be the problem one ?
    I honestly dont think its anything to do with the injectors at all mate. By reading this forum I think my inlet manifold is f##ked.

  9. #8
    Regular Member parsco's Avatar
    Join Date
    Sep 2008
    Location
    Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by collieq View Post
    Do I need to go through Vx to get the parts or can i souurce them myself?

    cheers for the input
    Stick with Vauxhall for the parts, this way the parts themselves are covered by a guarantee. It's more about the labour and Vauxhall themselves like to take the ****. I got quoted and charged 4 hours labour for the whole lot by my local garage at £35-40 per hour.

  10. #9
    Regular Member
    Join Date
    Jul 2009
    Location
    N. Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I got the repair kit of them for the 3rd injector. Just out of interest i asked how much to rewire it. The guy from parts headed off to the garage, came back and said ' the mechanic said it'd take about an hour and half to fit it. I asked how much. He said he'd do it for £95 all in. How nice, lol. 40 mins done it myself.

  11. #10
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    Part No for the turbo hose is 90543673 with a description of hose 5.3 I-D. Cost £1745 plus VAT.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9cdti 150bhp 55 plate vectra idle speed problem
    By Whiteknight841 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 21st January 2015, 07:55
  2. 1.9cdti 150bhp 55 plate vectra power steering stopped operating
    By Whiteknight841 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 13th June 2013, 14:21
  3. Vectra 1.9cdti 150bhp 0ver Fuelling.
    By wheelspin in forum Engine & Drivetrain
    Replies: 28
    Last Post: 9th February 2013, 23:38
  4. Loss of power issue (1.9CDTi SRi 150BHP, Vectra C)
    By Big Sie in forum Engine & Drivetrain
    Replies: 5
    Last Post: 20th April 2010, 17:46

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •