User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: New alternator, now emissions light...

  1. #1
    Regular Member Samdy Gray's Avatar
    Join Date
    Jul 2009
    Location
    Wiltshire, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default New alternator, now emissions light...

    Evening all. Hoping someone can shed some ideas on my problem.

    A bit of background: All my electrics failed (on Christmas Day of all days!). Started off with just the battery warning light coming on, which I stupidly ignored, but then gradually more and more lights started coming on until eventually the power steering failed and the dash lights went out completely.

    Thought it might've just been a flat battery at first what with the cold snap we've had lately. Started great first time after a healthy charge, but all the electrics failed again 300 yards up the road. Had the RAC out who tested the voltages etc. and said the battery was holding a charge and they diagnosed a failed alternator.

    Now for the new problem: Had a new alternator fitted today and it seems to be sweet as a nut (*touches wood*). When I first started the car the car/spanner light came on, but after turning the ignition off and re-starting it went away. However, the emissions light has now stayed on permanently. I've tried turning off the ignition and re-starting the engine a couple of times but it's not budging.

    Any ideas? Just seems strange to start after the alternator's been changed.

  2. #2
    Regular Member cerbrious's Avatar
    Join Date
    Apr 2008
    Location
    Wigan
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check any electrical connections especially around the alternator area sounds like a plug been knocked to me then remove battery for 30 mins to reset the ecu (you will need your radio code)

  3. #3
    Regular Member
    Join Date
    Mar 2008
    Location
    slough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Contact genral motors head office i got the no` from watch dog, gm they say they are not aware any problems on vectra`s ring on 08450902044. If enough people phone they have to do a re-call.............

  4. #4
    Regular Member Maverick's Avatar
    Join Date
    Jun 2005
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by cerbrious View Post
    check any electrical connections especially around the alternator area sounds like a plug been knocked to me then remove battery for 30 mins to reset the ecu (you will need your radio code)
    They don't have radio codes so you don't need to worry about that, but as said check connections and disconnect the battery. 10 minutes is all thats needed but 1/2 hour won't do any harm.

    Quote Originally Posted by hippo View Post
    Contact genral motors head office i got the no` from watch dog, gm they say they are not aware any problems on vectra`s ring on 08450902044. If enough people phone they have to do a re-call.............
    recall on what?

  5. #5
    Regular Member Samdy Gray's Avatar
    Join Date
    Jul 2009
    Location
    Wiltshire, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by cerbrious View Post
    check any electrical connections especially around the alternator area sounds like a plug been knocked to me then remove battery for 30 mins to reset the ecu (you will need your radio code)
    All sorted. Light's gone out and she appears to be running as normal.

  6. #6
    Regular Member cerbrious's Avatar
    Join Date
    Apr 2008
    Location
    Wigan
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    early ones with ccd type stereos need a code

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Emissions light
    By iain.condliffe in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 18th April 2013, 10:07
  2. emissions light
    By trickster75 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 19th May 2011, 21:10
  3. emissions light
    By lloyd_456 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 21st September 2009, 09:36
  4. Emissions Light
    By T4M in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 1st October 2008, 07:49
  5. Emissions Light
    By BigKev1970 in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 7th September 2007, 22:16

Visitors found this page by searching for:

changed alternator on car emmissions light on

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •