User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: 1.9CDTi Major Power Loss

  1. #1
    Regular Member
    Join Date
    Aug 2008
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 1.9CDTi Major Power Loss

    Hello There,

    Im Just finished cleaning the EGR Valve, using the Drill and Punch method, put it allback together, started the car and now there is no power, barely enough to rev on the spot!! there is alot of smoke from the exhaust.

    When i go into the Testmode on the main display, and press the BC button until the "CC" screen is displayed (one with all the zeros) there is a "4" on the bottom row, 10th digit in. (Store Row)

    Please help, My car is now stuck in my driveway as its on a slope!

  2. #2
    Regular Member Maverick's Avatar
    Join Date
    Jun 2005
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Was there a problem before you took the EGR valve apart?

  3. #3
    Regular Member
    Join Date
    Aug 2008
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeah it was dead upto 2300 revs approx! and then would fly! this pointed to EGR.

  4. #4
    Regular Member
    Join Date
    Aug 2008
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    just read a thread on "swirl bar and pots" see here> http://www.vectra-c.com/forum/showth...inlet+manifold

    the wee bar on my car in those pics in the above thread, is completely dislodged and just lying next to the Glow Plugs???

  5. #5
    Regular Member Maverick's Avatar
    Join Date
    Jun 2005
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Inlet manifold required then by the sounds of it.

  6. #6
    Regular Member
    Join Date
    Aug 2008
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    are they dear?

  7. #7
    Regular Member
    Join Date
    Oct 2009
    Location
    Teesside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    About £400 just for the parts

  8. #8
    Regular Member
    Join Date
    Aug 2008
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    awh great! i take it all the wee swirl flaps are ment to be in the same position?

  9. #9
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    i doubt the swirl bar is your main problem as your car is worse now than when you started!!, go over everything you've done, and make sure you've put the elec connector back on the egr. check how 2's for the 'repair swirl bar for a £1, well worth doing as mine's been working well for a couple of yrs.

  10. #10
    Regular Member
    Join Date
    Aug 2008
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have since stripped the EGR again and rebuilt it back onto the car... no bolts or plugs missed... will try the £1 fix...

    Thanks for the Speedy Replies Folks!

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Major loss of power
    By WeDesign in forum Engine & Drivetrain
    Replies: 130
    Last Post: 17th September 2012, 13:51
  2. major power loss and engine noise
    By martin.lake in forum Engine & Drivetrain
    Replies: 2
    Last Post: 17th September 2012, 00:13
  3. Loss of power, 1.9cdti sri 150
    By Lee_Pike in forum Engine & Drivetrain
    Replies: 22
    Last Post: 16th May 2012, 23:08
  4. EML on and major loss of power
    By chrislloydie in forum Engine & Drivetrain
    Replies: 27
    Last Post: 20th October 2010, 11:09
  5. Major loss of power
    By martinmack in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 7th November 2009, 18:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •