User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Vec C 2.2..... loss of power, won't drive over 2000rpm!!!!

  1. #1
    Regular Member
    Join Date
    Jan 2009
    Location
    Midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Vec C 2.2..... loss of power, won't drive over 2000rpm!!!!

    Hi.... need some help again......please
    My 53' reg 2.2 SRI (non direct) started to die on me on xmas eve.....I noticed that pressing down on the accelerator as I was driving there was no response at all then the power would suddenly return.....this gradually got worse and worse untill I had to use 1st and 2nd gear to limp home as it would not rev over 2000rpm!
    At 1st there was no EML on then when it did appear it was flashing.....I haven't drove it since and I'm now waiting for a dealer/garage to reopen to get it booked in, I've read on here about limp mode but didn't think it would be that slow if it was that.....any help or suggestions wod be great.

  2. #2
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Post Thanks / Like
    Mentioned
    47 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    47 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sorry mate hard one to even guess at you could check all hoses for splits ? ,best bet is what your doing give it to the dealers or even get a fault code reader and check faults yourself

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  3. #3
    On a Sabbatical
    Join Date
    Aug 2006
    Location
    EVERYWHERE
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    A £25 code reader (U480) off e-bay could save you hundreds in the long run.

    Sounds like classic EGR valve starting to stick and then sticking fully open symptoms.
    Last edited by diesel dog; 26th December 2009 at 15:51.

  4. #4
    Regular Member
    Join Date
    Jan 2009
    Location
    Midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Cheers for the help......I've cleaned the EGR about a year ago.....do you think it's worth a try wd40ing it and if not sort a new one?

  5. #5
    Regular Member
    Join Date
    Feb 2008
    Location
    norn iron
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    egr can be easily disabled on the 2.2, go to z22se for a how to! would be worth a try before spending any money

  6. #6
    Regular Member mark_647's Avatar
    Join Date
    Jun 2008
    Location
    Wales, UK
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    As above, you can blank it off and fit an EGR cheater..

    (www.z22se.co.uk)

  7. #7
    Regular Member
    Join Date
    Jan 2009
    Location
    Midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    That's great...I'll give that a go....thanks for the link

  8. #8
    Regular Member
    Join Date
    Jan 2009
    Location
    Midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi again....(another question)
    I've took the EGR off and the plunger/valve is fully out......is this the normal position when it's switched off?

  9. #9
    Regular Member
    Join Date
    Jan 2009
    Location
    Midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Update!!!!!!!

    Hi again,
    Just a update on what's happened...I've cleaned the EGR and throttle body....although it was quite clean any way. Then started it back up and it ran fine and no EML on...so hoping this was sorted went for a drive!!!!!
    3 miles later I was struggling to get back home as the fault returned

    So I had the car taken to the local dealers who said it had 27 seperate fault codes stored on it and were investigating these. From doing this they think it could be dirt in the tank so split the fuel tank and found swarf/dirt etc in there.
    They think that possibly the lifter pump or high pressure fuel pump has broken down (although i thought the non direct never had a H.P pump?)

    Does anybody in the know think this right......any help will be great!!!

  10. #10
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    All Vec hatch and saloon have the none direct SE up till 54 plate then they became the direct/YH. All Signims and Estates were fitted with the Direct/YH. You cant just blank a broke EGR, it has to be completely taken out of the system using the cheater or VX tech 2. You can only blank a working EGR as the ECU still needs to see it mechanically opening even if its not connected physically.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 30
    Last Post: 28th August 2012, 08:35
  2. My turn for no power under 2000rpm in Vectra CDTi (150) SRi
    By Ollie in forum Engine & Drivetrain
    Replies: 26
    Last Post: 27th March 2010, 18:40
  3. power loss below 2000rpm
    By Governor in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 9th February 2010, 16:25
  4. Autobox - Loss of Drive on 3.2 GSI
    By VinnyPeewee in forum Engine & Drivetrain
    Replies: 14
    Last Post: 17th June 2009, 13:42
  5. what should the power be like under 2000rpm
    By learoy69 in forum Vectra C / Signum Car Chat
    Replies: 20
    Last Post: 12th March 2008, 16:30

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •