User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: 2.0 Turbo. No Spark

  1. #1
    New Member
    Join Date
    Dec 2009
    Location
    Wexford Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.0 Turbo. No Spark

    Hi. New To forum and looking to pick everyones brains,


    I have a 2003 Vectra 2.0 Turbo. (saab Engine). Giving problems with spark. Will start and run for anywhere between 10 seconds and 5 minuts then cut out and may start again but if so only for same again the n when it won't start it is due to no spark.

    Was messing with relays earlier and swapped R7 under bonnet and it stated and ran longer than normal then wouldn't start again... Removed and re installed relay and started again. maybe a coinsidence or maybe connected. Anyone know what R7 for???

    Fauld codes showing up....

    p1315
    p0102
    p2301
    p2307
    p2304
    p2310

    They relate to.... Persistant misfire, Mass air flow, and 4 faults for coil packs. (a, b, c, d)

    Since swapping relay etc today and clearing all codes onl showing mass air flow fault. Have unplugged air flow meter and still dies and no spark as always.....

    PLEASE HELP........

  2. #2
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2t

    Trim : standard

    Engine : z20net

    Year : 08

    Mileage : 32000

    Smile

    Might not help...BUT....have you tried cleaning your air flow meter?..I used a can of carb cleaner sprayed at the part directly..cleared my 'fault'..just a thought.

    Was done on the car btw,simply unsrewed the jubilee clip behind the air box and sprayed down tube(with the extension/thin pipe that came with the cleaner).

  3. #3
    Regular Member Craig1985's Avatar
    Join Date
    Dec 2007
    Location
    harwich essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what about flywheel sensor? think this is the one (the one with the little magnet on) this was the case when my bros pug had no spark/fuel

  4. #4
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    p1315 - P1315 Persistent Misfire
    p0102 - P0102 Mass or Volume Air Flow Circuit Low Input
    p2301 - Ignition Coil 'A' Primary Control Circuit High
    p2307 - P2307 Ignition coil C, primary circuit - circuit high
    p2304 - P2304 Ignition coil B, primary circuit - circuit high
    p2310 - P2310 Ignition coil D, primary circuit - circuit high

    Out of interest what code reader did you use?

    I'd be looking at the Maf and then the coil pack
    Now I need a turbo to keep up!

  5. #5
    New Member
    Join Date
    Dec 2009
    Location
    Wexford Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for replies. Not flywheel sensor as it putting a reading of 200rpm on crank when no spark. Not airflow as still not showing spark when unplugged and there 4 seperate coil packs not just one. The coil packs get power and earth. They are 4 wire coils. Other 2 wires are trigger and ion system. Ion system. The ion system is not causing the issue so it must be the trigger that the problem so either the ecu or a wire issue. That's all we can narrow down to at this point. Anyone know what R7 relay for?

    And in answer to your question Bigsig. Using 2 different scan tools. A Sealy scanner and vaux com on laptop with lead. I knew what the trouble codes were just posted them in case it helped anyone with ideas. Just trying to brainstorm with everyone here. These forums are great. The vectra my everyday runner but have a few classic minis and regular user of mini forums.

    Thanks for help so far lads if you think of anything else please post.
    Cheers.

  6. #6
    New Member
    Join Date
    Dec 2009
    Location
    Wexford Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok really starting to hate the car now. May have tracked it to ecu. Can you reprogramme a second hand and it so do I need key and key reader to match or just the ecu? Also been told that as a matter of course should replace all 4coil packs as they may have killed the ecu in first place. This true? Anyone recommend a place icould call for these parts or even some advice?

  7. #7
    Regular Member n_hudson's Avatar
    Join Date
    Mar 2008
    Location
    Northampton, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Z20NET ECU on Ebay - Brand new, never used (Not Mine) HERE

    Not sure if this is any use to you - HERE

    I've had a few things of this seller and they seem to have a lot thats not listed too.

    I would have thought, like most parts, if a used ECU is removed correctly and unpaired etc that it should work?

  8. #8
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2t

    Trim : standard

    Engine : z20net

    Year : 08

    Mileage : 32000

    Default

    Have you tried MEGAVOX in Nottingham?...only break vauxhalls and very helpfull and reasonable..google em..

    http://www.megavaux.co.uk/...would help if i could spell...dohh
    Last edited by n_hudson; 30th December 2009 at 12:49.

  9. #9
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by nikroc View Post
    Have you tried MEGAVOX in Nottingham?...only break vauxhalls and very helpfull and reasonable..google em..

    http://www.megavaux.co.uk/...would help if i could spell...dohh
    And they have a Tech2.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 19
    Last Post: 6th September 2014, 13:54
  2. Turbo Technics Hybrid turbo details.
    By nutron in forum Diesel Engine related
    Replies: 13
    Last Post: 28th February 2011, 22:57
  3. Spark plug Part No. 2.8 Turbo
    By Del in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 24th November 2009, 23:00
  4. Spark!
    By siz1 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 4th November 2009, 22:28
  5. 2.0 turbo spark plugs
    By lee in forum Engine & Drivetrain
    Replies: 9
    Last Post: 27th March 2009, 15:45

Visitors found this page by searching for:

wiring P0102 mass flow vectra c forum

opel vectra c P2304

vectra 2.8 no spark

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •