User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Stupid Battery

  1. #1
    Regular Member P-Mutton2.2's Avatar
    Join Date
    Aug 2009
    Location
    Frinton on sea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Stupid Battery

    Gave a bloke stuck in a car park a jump start this morning,... how unhelpful are the terminals on the Battery?..., no sign no nothin.

  2. #2
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    I'm just damn glad you didn't say 'jumped a guy in a car park this morning' .... goodwill to all men only goes so far !

    I've come across one or two car/van batteries over recent years where the + & - markings were actually the sticky label on the front face of the battery rather than the more common and helpful location on top beside each terminal, as most manufacturers seem to put them.

  3. #3
    Regular Member P-Mutton2.2's Avatar
    Join Date
    Aug 2009
    Location
    Frinton on sea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I mean i couldnt see any indication of positve/neutral at all.

  4. #4
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    Quote Originally Posted by P-Mutton2.2 View Post
    I mean i couldnt see any indication of positve/neutral at all.
    Damn lucky there's a couple of nice, brown cables going to the -ve and red ones to the +ve then.... but deffo not what you need when you're freezing your proverbals off !

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. battery wiring block next to battery 150tdci - HELP
    By jameslunt in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 2nd July 2012, 07:19
  2. stupid question but...im stupid..
    By nicj in forum General Chat
    Replies: 15
    Last Post: 18th March 2009, 23:00
  3. Stupid ****** kids and their stupid ****** fireworks!
    By SignumPhil in forum The 'Off Topic' room
    Replies: 23
    Last Post: 7th November 2008, 12:06
  4. Stupid People Doing Stupid Things
    By Jay Kay 313 in forum Comedy & Humour
    Replies: 1
    Last Post: 15th November 2007, 08:56
  5. stupid stupid stupid question- 3.0dti badge
    By Adamdavi3s in forum Styling
    Replies: 31
    Last Post: 17th August 2007, 06:32

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •