User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Limp mode under acceleration - 3.0 CDTi

  1. #1
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default Limp mode under acceleration - 3.0 CDTi

    English is not my mother tongue so bear with me if I get things wrong.

    My 3.0CDTi has very poor performance under 2000rpm and over 3500rpm. Lately the boost peak is happening at 2250rpm and pulls strong for about 1250rpm.

    I noticed a very odd thing the other day. The engine was running at a reasonable 1800rpm in 6th gear. I wanted to speed up a bit but knowing it has no power I changed down into 5th so it was just over 2000rpm. I held the revs for 10seconds or so, because there was someone flying by, then I floored it but the engine didn't flinch until the revs came up to 2500-3000.

    Earlier today it went into limp mode when I was overtaking a lorry. 6th gear @1900rpm.
    Diagnosed as Low boost pressure.

  2. #2
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Lol your english may be better than mine

  3. #3
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Quote Originally Posted by john.robertson2 View Post
    Lol your english may be better than mine
    Not what I wanted to hear, but thanks mate

  4. #4
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    is it a pre face lift as they suffer with sticking turbo veins causing under or overboosting

  5. #5
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    It's a 2003 Y30DT. Checked on Tech2 and the car is UNDERboosting. 0.2bar off.

  6. #6
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Why the hell can't it just be a sensor. Can't be arsed to take the turbo off!

  7. #7
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    try a sensor first its just had a overboost fault on my y30dt where low revs and using the torque brings the light on. mine was over boosting. you can try cleaning/changing the sensor but sticky turbo's do seem a bit of a comon problem cause vx technical told me to fit it as been other cases

  8. #8
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    I cleaned the boost sensor, to no avail. Spoke to Opel tech and he said it's probably a boost sensor problem.
    I'm used on spending money for repairs that another 115€ don't bother me much...If a new boost sensor won't help then another 350€ will fly out of the window
    But it's so annoying...always something wrong with it! Can't enjoy the beast and its true potential!

  9. #9
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    poor thing was lucky and my warranty covered it might be the distance drives you do made it last so long 40k miles mine died

  10. #10
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Either way...to the dealer tomorrow to place an order for a spanking new Hitachi Boost Sensor for Y30DT engine

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 3.0 V6 CDTi occasional limp mode...
    By fandango in forum Engine & Drivetrain
    Replies: 53
    Last Post: 21st June 2016, 13:24
  2. Cdti limp mode???.
    By steve1312 in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 26th July 2012, 00:46
  3. Please help?? 1.9 cdti 150 limp mode p1125
    By rsvphil in forum Engine & Drivetrain
    Replies: 5
    Last Post: 24th September 2010, 13:43
  4. Signum 1.9 CDTi limp mode
    By doublek500 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 6th June 2010, 22:26
  5. 1.9 cdti 150 limp mode
    By jeets in forum Introduce yourself.
    Replies: 0
    Last Post: 30th May 2009, 20:29

Visitors found this page by searching for:

3.0 cdti hesitant acceleration site:www.vectra-c.com

v6 cdti hestitant acceleration

what other turbo can i put in a 3.0 cdti vectra c

https:www.vectra-c.comforumshowthread.php98019-Limp-mode-under-acceleration-3-0-CDTi

3.0 cdti limp mode after hard

vauxhall vectra limp mode when accelerate

vectra low boost in sports mode

09 1.9 cdti vectra goes into limp mode when accelerating

what cause my insignia to go into limp mode when i accelerate

bt50 3.0 crdi in limp mode when accelerate

insignia goes into limp mode in sixth gear

acceleration limping

clean veins in turbo 1.9cdti

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •