User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Display

  1. #1
    New Member
    Join Date
    Jun 2009
    Location
    Norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Display

    My 2004 (04) TID display kept freezing and draing the battery, had a new one fitted today, but the functions of Range, Trip Consumption and Consumtion are showing F. The range did flash 489 and then went back to F. The dealer says I just need to re-fill the tank to re-set it. I have done and no joy. Any ideas?

    Thanks in advance and MERRY CHRISTMAS.

  2. #2
    Regular Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Have you done many miles since the display was fitted?

    On the odd occasion, it has been necessary to do a certain amount of miles, before the display provides a reading...
    Dependent upon the set up, I have heard of this being as little as 6 miles, but more commonly it is around 50 miles before you get a useable display.

    If there is still a problem after a reasonable mileage, then it should go back in to the garage...they may not have programmed in all the modules of the car to see / communicate with the display.

    Or there could be a loose wire to the display plug. (if you know how to get at the display plug, then you could check the wires and the seating of the connector plug).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replacing Board Info Display (BID) with Color Info display (CID)
    By grigs1 in forum Electrical & ICE (including SatNav)
    Replies: 49
    Last Post: 11th April 2012, 22:13
  2. mp3 on display
    By marc vectra sri in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 27th August 2011, 14:54
  3. PS3 display
    By @ndy-e in forum Games Room
    Replies: 2
    Last Post: 27th December 2010, 08:21
  4. temp display on radio display
    By MRunMotorsport in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 19th April 2010, 15:55
  5. LED DIsplay
    By dcraigen in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 18th September 2008, 10:16

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •