User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: A.b.s/traction control warning lights

  1. #1
    Regular Member dudley6623's Avatar
    Join Date
    Sep 2009
    Location
    skegness lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI

    Engine : 2.0L Turbo

    Year : 04/54

    Mileage : 88000

    Smile A.b.s/traction control warning lights

    Im after some help/advice, got my car (54plate vectra sri 2.2) stuck in the snow tonight, after much wheel spinning and strugling i got free, but i now have both the a.b.s and traction control warning lights on!!!! Anyone any ideas what has caused this??

    many thanks

  2. #2
    Regular Member
    Join Date
    Jan 2009
    Location
    Near Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    They should not of stayed on,sumtimes when they stay on they reset after driving a short distance,try the car again in the morning and if still on i also try disconecting the battery for half an hour and see how you get on 1st....

  3. #3
    Regular Member MalcGSI's Avatar
    Join Date
    Mar 2006
    Location
    E Sussex & Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Wife had this Thursday night after getting stuck in the snow \ ice. All OK when she went back to the car on Friday morning though so hopefully you'll be OK.

  4. #4
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Maybe as they stopped fitting TC switches on the dash the ECU was programmed to turn it off when needed itself??? Hence the light staying on?

  5. #5
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    Good chance as mentioned it was the ABS/TC ECU going into tilt mode due to the extremes of differences in wheelspeeds at the same time and/or accumulation of ice/packed snow at the sensors.
    Leave it to sit/thaw and it'll most likely be fine.

  6. #6
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It will probably be ok, its just that it cannot understand why its needing the Tc and then the ABS so it throws a wobbly.
    Now I need a turbo to keep up!

  7. #7
    New Member BiggDaddyT's Avatar
    Join Date
    Dec 2009
    Location
    Newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default A.b.s/traction control warning lights plus speedo stoped at the same time???

    Hi Everybody,

    I am experiencing these same problems after an evening spinning in heavy snow, the abs/traction control lights have stayed on, but my speedo has also stopped working?? the rev counter is still working though? this hapened yesterday, since then ive checked all the fuses today which are all ok. ive had the car running for a couple of hours to try and thaw it out after reading the comments about the sensors being packed with ice.

    Please hit me with ideas, cheers

  8. #8
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    Quote Originally Posted by BiggDaddyT View Post
    Hi Everybody,

    I am experiencing these same problems after an evening spinning in heavy snow, the abs/traction control lights have stayed on, but my speedo has also stopped working?? the rev counter is still working though? this hapened yesterday, since then ive checked all the fuses today which are all ok. ive had the car running for a couple of hours to try and thaw it out after reading the comments about the sensors being packed with ice.

    Please hit me with ideas, cheers
    The data for the speedo is also affected by the wheelspeed sensors... leave it all to thaw/reset and you'll probably be fine.

  9. #9
    Regular Member VECTRAMAN's Avatar
    Join Date
    Apr 2007
    Location
    Bridgend/South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 1.9 CDTI Design Estate

    Trim : Half leather

    Engine : 1900

    Year : 2006

    Mileage : 116k

    Default

    Had this myself last year. After stopping my journey and restarting again later that day the light simply went out after a short distance. Must have been the sensors resetting themselves.
    Hope yours clears up.

  10. #10
    New Member BiggDaddyT's Avatar
    Join Date
    Dec 2009
    Location
    Newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks bud, did your speedo go off when these lights came on? another thing i would like to ask is when a bought my car, i never recieved my vauxhaul car pass? this means if i want to disconect the batery to try and reset everything my stereo will go off and i cant put the code in as i dont have one?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Abs and Traction Control warning lights on in 2002 Vectra C 2.0dti
    By Dori_Rory in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 8th February 2013, 18:20
  2. ABS & Traction control lights on?
    By keithsimmo in forum Suspension, Wheels & Brakes
    Replies: 23
    Last Post: 3rd January 2013, 20:17
  3. traction control and abs lights on....?
    By jungle in forum Suspension, Wheels & Brakes
    Replies: 11
    Last Post: 18th February 2010, 21:22
  4. Traction Control Warning Light
    By oldmanmille in forum Electrical & ICE (including SatNav)
    Replies: 14
    Last Post: 12th December 2009, 22:16
  5. a.b.s. traction control lights
    By simplesi in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 12th August 2009, 11:40

Visitors found this page by searching for:

vectra c 2.0dti clocks stop working tc light

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •