User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: URGENT-anyone heard of "ECU needs update" after EGR Valve repalcement on CDTI 150?

  1. #1
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default URGENT-anyone heard of "ECU needs update" after EGR Valve repalcement on CDTI 150?

    Hello all,

    Ongoing CDTI 150 issues.
    I had the dad's motor over the weekend and to say it is gutless under 1.8k rpm is an understatement!

    I was driving it over the weekend and went to London and the car just crawls under 1.8k rpm and its downright dangerous!!!

    Even on the motorway, it just wont drive at 50mph in 6th gear, I was having to go down a gear to 5th and even 4th just to get me above 2k rpm so it would continue. At one point I was in 6th going at 51mph, then it gradually came down to 47/46 and doing about 1.2k rpm, had to kick down to get it back to 50 mph! Disgraceful!

    ANYWAY, I have just had a chat with Vx dealers and told them that I have done the EGR Valve and now it has B-NEW one on there, have also told them about the 3rd Injector, air filter, Millers additive, etc and the lady on recpetion asked if the system had been updated since the EGR repalcement?
    I asked do you mean has the code been cleared, if SO, then YES it has. And she said NO, the system will need updating with a Tech2 to say it has been replaced as the system is still showing as code present, even if its been cleared! She said the car ECU is reading the as EGR being closed so the code needs to be cleared and updated to show back as open state!

    I said is this causing the wobbling at idle, she said more than likely as the car has got to much/less gasses going through the EGR valve so its running bad, blah blah blah blah blah, etc!

    First I've heard of this....can someone please assist as im tempted to get it booked back in, £50.00 for Tech2 Diags and system update!!!

    The car is still every now and then throwing up a "P0400" EGR Valve code which im clearing once every 3 weeks, had to do one on Saturday before I took it!

    So is she right!?

    PLEASE PLEASE !!

    She also said that if we have suspicions with the EGR valve, if I can give them the receipt for it, then she can get me a replacement just to eliminate the process!!

    In advance, Thank you again Vec-C members and I am dying to hear your feedback on this!




    .


    Bye bye Vec B
    - Hello Siggy!

  2. #2
    Regional Organiser - West Scotland neverlandandy's Avatar
    Join Date
    Sep 2006
    Location
    lanark
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    don't know exactly if shes right but i had my egr replaced last week and an ecu software upgrade but i'm not sure if the two had to be done together

  3. #3
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by neverlandandy View Post
    don't know exactly if shes right but i had my egr replaced last week and an ecu software upgrade but i'm not sure if the two had to be done together
    Hmmm.....god knows mate, probably not in Vx's case as it means you would have to go back for an extra charge! Just out of interest, what was your car doing before and after the EGR & Software upgrade, etc?



    The rest of you: 19 views so far, come on folks, me out here please!


    Bye bye Vec B
    - Hello Siggy!

  4. #4
    Regional Organiser - West Scotland neverlandandy's Avatar
    Join Date
    Sep 2006
    Location
    lanark
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    as per egr very flat spot at low revs under 2.0k rpm and thats about it really it now runs like a dream but like i say i don't know if the ecu update was paired with the fitting of the new egr

  5. #5
    Regular Member
    Join Date
    Jul 2009
    Location
    sussex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    sounds like a load of balls to me.
    they are told to speak horse shi* to create more revenue!

  6. #6
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Post Thanks / Like
    Mentioned
    136 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    136 Post(s)
    Tagged
    0 Thread(s)

    Default

    ooh wait... theres something brewing.... think she's half right

    There is a new ECU revision which alters the characteristics of the EGR's operation. Not sure when/if it has touched down yet but I remember someone said it was soon.

    It wont make any difference to the fault code appearing every now and again and there is nothing to clear once the code has been read and wiped. Your problem sounds very much like a turbo issues, we had this with Jay Kay 313's car. It would be gutless in 6th gear and would need to drop down to build up power, it eventually got so bad he had to keep dropping to lower and lower gears over the course of time.... Result was new turbo required....

    Think its all the slush and mush in it, at low rpm high gear not enough exhaust pressure to spin it up properly but lower gear higher rpm and it would be ok...
    Plasma's Tech2 services are now partially open and able to provide services



    Come Join our new forum Insignia Owners.com for all your Insignia chat and needs

  7. #7
    Regular Member paul wingnut's Avatar
    Join Date
    Mar 2009
    Location
    durham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    if the valve was replaced and code cleared everything should be ok there is no update yet for the 150 so i think she is talking s**t the only update was for the z19dt

  8. #8
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by plasma View Post
    ooh wait... theres something brewing.... think she's half right

    There is a new ECU revision which alters the characteristics of the EGR's operation. Not sure when/if it has touched down yet but I remember someone said it was soon.

    It wont make any difference to the fault code appearing every now and again and there is nothing to clear once the code has been read and wiped. Your problem sounds very much like a turbo issues, we had this with Jay Kay 313's car. It would be gutless in 6th gear and would need to drop down to build up power, it eventually got so bad he had to keep dropping to lower and lower gears over the course of time.... Result was new turbo required....

    Think its all the slush and mush in it, at low rpm high gear not enough exhaust pressure to spin it up properly but lower gear higher rpm and it would be ok...
    My issue is mainly with the flat spot below 2k rpm! Is that what all this is about. Problem is its worse than a flat spot now, its more of a dead spot.

    Is there no way of clearing out the Turbo?


    Bye bye Vec B
    - Hello Siggy!

  9. #9
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Post Thanks / Like
    Mentioned
    136 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    136 Post(s)
    Tagged
    0 Thread(s)

    Default

    obviously get a garage to diagnose it first before you take any action, but it seems you've covered all of the normal culprits. As for the turbo its gonna need a service, has to be removed from the car and sent off to turbo technics or such...
    Plasma's Tech2 services are now partially open and able to provide services



    Come Join our new forum Insignia Owners.com for all your Insignia chat and needs

  10. #10
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by plasma View Post
    obviously get a garage to diagnose it first before you take any action, but it seems you've covered all of the normal culprits. As for the turbo its gonna need a service, has to be removed from the car and sent off to turbo technics or such...
    !!!!!


    Bye bye Vec B
    - Hello Siggy!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anyone heard of "MEYLE" shock absorbers??
    By si_hoss in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th August 2011, 17:08
  2. Vauxhall - "Free software update"
    By Ian-Highlander in forum Vectra C / Signum Car Chat
    Replies: 31
    Last Post: 23rd March 2011, 20:36
  3. GSi "ticking" valve - oh dear??
    By gtr1000 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 21st September 2009, 19:22
  4. Anyone heard of "Just Car Clinic"?
    By rushy in forum General Chat
    Replies: 11
    Last Post: 7th March 2007, 09:45

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •