User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Help with fault code,

  1. #1
    Regular Member robwilson69's Avatar
    Join Date
    Oct 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Help with fault code,

    Hi all i have the steering wheel light on the dash, i today conencted a tech 2 and read the CIM module and i have fault (steering wheel angle sensor) what is this why would it be at fault?

  2. #2
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi it could be you need to calibrate the sensor. try this first. If you go into calibration you have to turn steering wheel left press ok the nright ok then centre ok. job done.

  3. #3
    Regular Member robwilson69's Avatar
    Join Date
    Oct 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks tried this but DTC will not clear keeps coming back.., i have changed pump but dont know if this fault was there before pump was fitted, i have no problems with steering at all just the annoying light giving this error code..

  4. #4
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The steering angle sensor is on the steering rack. but I think the CIM is at fault. New sims are about £180. you will need tech 2 to program this in. You can get one off ebay but make sure its been reset from the donor car. Also make sure it has esp if you car has esp. facelift and pre facelift sims are different.

  5. #5
    Regular Member robwilson69's Avatar
    Join Date
    Oct 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks as mine is facelift 2007 were would i find the CIM module in the car, do you think it has anything to do with the change of the power steering pump...

  6. #6
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    CIM is wrapped around the top of the steering collumn, behind the airbag squib and the steering wheel.

    If the steering rack has been worked upon, have you ensured that all connectors are clean and securely fastened.

    As an outside consideration...the CIM and other modules rely on several fuses to function and to communicate properly.

    Check the fuses in the end of the dash...

    If none of this works, then it may need a replacement CIM.

  7. #7
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    its nothing to do with the pump. The steering angle sensor is on the steering rack. but I think the CIM is at fault. New sims are about £180. you will need tech 2 to program this in. You can get one off ebay but make sure its been reset from the donor car. Also make sure it has esp if you car has esp. facelift and pre facelift sims are different. I have just checked ebay . There is 2 onthere but are for police cars so do not go there. If you need one call 0708 384720 vx spares romford. that where I got mine and they are very helpfull.

  8. #8
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    256 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    area code should be 01708 not 0708, just a typo I guess
    Plasma's Tech2 services are now partially open and able to provide services



    Come Join our new forum Insignia Owners.com for all your Insignia chat and needs

  9. #9
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sorry mised that 1. sorry

  10. #10
    Regular Member robwilson69's Avatar
    Join Date
    Oct 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok thanks for all your replys i have a tech 2 luckily i have noticed that the steering rack arm has been changed witch i now think this is def a calibration issue, i check in live data and the sensor is working when i turn left and right, i only just got my tech 2 and not sure if i am doing it right to calibrate has anyone here know how to calibrate the sensor using the tech 2?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fault code help :(
    By Thom in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 4th February 2012, 20:14
  2. Fault code help!!!
    By billy88 in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 22nd April 2011, 16:02
  3. help with a fault code
    By jan65uk in forum Engine & Drivetrain
    Replies: 1
    Last Post: 15th December 2009, 20:57
  4. Fault Code?
    By CDTi-SRi-Matt in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 26th February 2009, 21:43
  5. Fault Code?
    By CDTi-SRi-Matt in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 26th February 2009, 21:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •