User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Dreaded spanner light

  1. #1
    Regular Member
    Join Date
    Oct 2009
    Location
    N.Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Dreaded spanner light

    Hopefuly somebody could help me out here, iv a 2005 1.9cdti 120bhp vectra design with 70k on the clock, love the car but iv noticed that the spanner light comes on.

    It only happens when there is no heat in the engine and it goes off after about 3 minutes, when its on the car drives perfect no limp mode or anything. Im thinking could it be the glow plugs because it only happens 1st start of the day? Also can i just carry on driving the car, problem is im a bit broke with xmas only around the corner lol but i dont want to damage the engine.

    Cheers

  2. #2
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRI VX-Line Nav

    Engine : 2.0 CDTI [170 PS]

    Year : 2015

    Mileage : 27000

    Default

    most likely yes. Does the glow plug light come on too? if not then there could be some sensor failure - ie engine thinks the ambient temperature is warm but cant crank over.

    Does the engine take a while to crank over? if not it may be a stored fault code that is obsolete and will eventually stop coming on.

    Sounds like its something stupid.

    Gazza4
    Insignia VX-Line Nav CDTI 170.

  3. #3
    Regular Member
    Join Date
    Oct 2009
    Location
    N.Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gazza4 View Post
    most likely yes. Does the glow plug light come on too? if not then there could be some sensor failure - ie engine thinks the ambient temperature is warm but cant crank over.

    Does the engine take a while to crank over? if not it may be a stored fault code that is obsolete and will eventually stop coming on.

    Sounds like its something stupid.

    Gazza4
    No mate it starts no problem, im really hoping its something stupid, if i turn the engine off and back on again the light doesnt come back on. I recently changed the fuel filter would this have anything to do with it maybe?

  4. #4
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRI VX-Line Nav

    Engine : 2.0 CDTI [170 PS]

    Year : 2015

    Mileage : 27000

    Default

    tbh im no expert but i dont imagine changing a fuel filter is going to do much. Did it start doing it immediately?

    If it starts no problem and the spanner light is coming on I personally wouldnt be concerned.

    A spanner light with limp mode/starting problems there will be something but if its on its own there is nothing much to worry about.

    I would however - like any other member - recommend getting the fault codes read before making judgement on it.

    A spanner light that comes on then goes out at start up means there is a fault code stored but the fault has cleared. But it wont do you harm to get it read though.

    Gazza4
    Insignia VX-Line Nav CDTI 170.

  5. #5
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Even although it starts no problem i'd still be looking at glow plugs, one may be on its way out and the car will be picking up on this.

  6. #6
    Regular Member
    Join Date
    Oct 2009
    Location
    N.Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the feedback is there any way of reading the fault codes yourself without paying vauxhall? I know on my old 2.0l petrol mk4 astra you could use a paper clip lol

  7. #7
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    lol not quite as simple as that on the Vec i'm affraid, a decent code reader from ebay will do it though

  8. #8
    Regular Member
    Join Date
    Oct 2009
    Location
    N.Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by john.robertson2 View Post
    lol not quite as simple as that on the Vec i'm affraid, a decent code reader from ebay will do it though
    Lol cheers mate

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The Dreaded Spanner Light
    By alhambra in forum Engine & Drivetrain
    Replies: 6
    Last Post: 13th November 2011, 11:31
  2. Dreaded spanner light
    By gnomes in forum Engine & Drivetrain
    Replies: 3
    Last Post: 17th December 2010, 13:59
  3. The dreaded spanner light :-(
    By woody in shetland in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 11th October 2008, 21:00
  4. dreaded spanner light when accelerating
    By formby in forum Engine & Drivetrain
    Replies: 5
    Last Post: 6th May 2008, 22:21
  5. The dreaded spanner light
    By Finty in forum Vectra C / Signum Car Chat
    Replies: 16
    Last Post: 4th February 2008, 21:04

Visitors found this page by searching for:

corsa c diesel spanner light comes on when engine warm

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •