User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Spanner light on at low revs.

  1. #1
    Regular Member arnie_barney's Avatar
    Join Date
    Nov 2007
    Location
    Omagh, Co.Tyrone, N.Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry Spanner light on at low revs.

    Looking for some help.
    My spanner light comes on intermittently at idle revs, say when you are sitting at traffic lights, you are watching the lights, they go green, you take off but no power, look down at the dash and the spanner light is on AAAGh. Turn the keys on and off and its gone. Sometimes it will go away if you give it a rev but only with no load on the engine.

    Anyone got any idea what is causing this, it doesn't do it under acceleration at all.

  2. #2
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Fault code(s) need reading out. Takes away all the guesswork.

  3. #3
    Regular Member arnie_barney's Avatar
    Join Date
    Nov 2007
    Location
    Omagh, Co.Tyrone, N.Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The spanner was coming on every time I was idling so I brought it to the dealers to read the fault code. 2.2dti - It was a differance in vaccum pressure but he checked the vaccum pressure and it was ok.
    He took off a sensor under the top engine cover above the egr valve and dissappeared with it - he came back and said there was dirt in it and that the sensor in question checks the vaccum pressure, so the dirt was not letting it read the correct level. Spanner has not came on since.

    And the cost of this trip to Vauxhall. 'Happy Christmas this ones on the house'. Thanks Gormleys - Vauxhall - Great guys.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 30000 revs spanner light .limp mode .vectra 2.0 dti 2004
    By davemander in forum Engine & Drivetrain
    Replies: 7
    Last Post: 19th February 2013, 00:07
  2. Reluctant start, revs dipping and car with spanner light
    By coldo in forum Engine & Drivetrain
    Replies: 15
    Last Post: 12th November 2012, 23:51
  3. Spanner light and loss of power at low revs
    By Marky in forum Engine & Drivetrain
    Replies: 4
    Last Post: 29th April 2010, 16:34
  4. 2.2dti only revs to 2600 rpm- spanner light on
    By nutty0069 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 25th January 2009, 15:42
  5. Spanner light at low revs?
    By ChrisFox in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 11th September 2007, 19:11

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •