User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: ECU and mpg

  1. #1
    Regular Member benwalters82's Avatar
    Join Date
    Nov 2009
    Location
    Redruth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SXI

    Engine : 2.0DTI

    Year : 2002

    Default ECU and mpg

    I do 150 miles a day commuting (majority dual carriageway doing 70-75) but i'm only returning 43-45mpg.

    Is this a bit low?

    2.0 DTI SXI 52 plate

    Bought the car a month ago prior to which it had a new ECU fitted by non-dealer garage. Could this be affecting the mpg?

    Cheers

  2. #2
    Regular Member
    Join Date
    Jun 2009
    Location
    Newark-on-Trent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine is 2.2 DTI.
    If I drive normally between 70-75mph I usually get around 48-51 mpg.
    If I drive up to 70mph I can get up to 55 mpg on long journeys.
    If I drive between 80-90 mph I get around 42-46 mpg.
    Around city I get around 45 mpg.
    Mine average on all driving is around 46-47 mpg.

  3. #3
    Regular Member Keithy's Avatar
    Join Date
    Jan 2008
    Location
    Dundee
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Luke52 View Post
    Mine is 2.2 DTI.
    If I drive normally between 70-75mph I usually get around 48-51 mpg.
    If I drive up to 70mph I can get up to 55 mpg on long journeys.
    If I drive between 80-90 mph I get around 42-46 mpg.
    Around city I get around 45 mpg.
    Mine average on all driving is around 46-47 mpg.
    That sounds about right for me

  4. #4
    Regular Member benwalters82's Avatar
    Join Date
    Nov 2009
    Location
    Redruth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SXI

    Engine : 2.0DTI

    Year : 2002

    Default

    thought it was on low side. any idea? Ecu? to blame?

  5. #5
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    When was it last serviced??

  6. #6
    Regular Member
    Join Date
    Jun 2009
    Location
    Newark-on-Trent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It's hard to say. It might be software on ECU, but also hundreds of other reasons.
    I had a lot of problems with mine before - got it all sorted now, but it costed me a fortune.
    When you drive, does it pull completely normally or do you feel is weak? Also does it smoke when you accelerate?
    If not it might as well be normal Vectra is 1600 kg car and weaker engine might need to work harder. It would help if any 2.0 DTI owners would let you know how theirs are doing.

  7. #7
    Regular Member benwalters82's Avatar
    Join Date
    Nov 2009
    Location
    Redruth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SXI

    Engine : 2.0DTI

    Year : 2002

    Default

    Re : Service - based on the other problems i've had on the car (http://www.vectra-c.com/forum/showthread.php?t=94880) not for a long time.

    When i first put foot down it is a bit weak but picks up after 2k revs, smokes on first start up when cold but not sure bout driving normally - don't notice anything

  8. #8
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Try giving it a service and check all vacuum pipes/boost pipes for splits

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •