User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: oil light flickers

  1. #1
    Regular Member
    Join Date
    Sep 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default oil light flickers

    Hi all,

    I have a 53 vectra 2.2dti, after the engine is fully warm the oil warning light on the dash flickers, I have changed the oil and filter.

    Anyone have any ideas on what it could be or anyone had anything similar?

    any advise would be much appreciated...

    steve

  2. #2
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Have you put enough oil in? The oil should be checked warm on a DTi

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Also what grade of oil was it? Did the light flash before?
    Now I need a turbo to keep up!

  4. #4
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Quote Originally Posted by Big Sig View Post
    Also what grade of oil was it? Did the light flash before?
    Very good point although I run 0w-30 in my dti and thats about as thin as you can get and have no lights. Although it could be a faulty oil pressure switch

  5. #5
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by john.robertson2 View Post
    Very good point although I run 0w-30 in my dti and thats about as thin as you can get and have no lights. Although it could be a faulty oil pressure switch
    Yes, but no two engines are the same.
    Now I need a turbo to keep up!

  6. #6
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Quote Originally Posted by luckyracer View Post
    Hi all,

    I have a 53 vectra 2.2dti, after the engine is fully warm the oil warning light on the dash flickers, I have changed the oil and filter.

    Anyone have any ideas on what it could be or anyone had anything similar?

    any advise would be much appreciated...

    steve
    On re-reading what you have written you say you changed the oil, was this an attempt to cure the flickering light? Also what warning light is it? The pressure light or the oil level light

  7. #7
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thats it John, keep it up
    Now I need a turbo to keep up!

  8. #8
    Regular Member
    Join Date
    Sep 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the interest guys, I changed the oil to try and cure the problem, I have checked the levels and they are fine, its the oil light that comes on with the ignition, the oil level warning light I assume.
    It only does it when the engine is really warm and when idling, the second I touch the accelerator to pick up the revs it goes out.

  9. #9
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Maybe the oil pump!?!

  10. #10
    Regular Member
    Join Date
    Sep 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just an update, I had the drive belt tensioner go the other day, the car ended up in the stealers, thought that may be a fix for this, but ...no. is still doing it, when I pick up the revs even the slightest amount the oil light goes out... so dont think it is the oil pump.. is the oil pressure, or level switch the sensor at the bottom of the sump?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Original xenon (AFL) flickers and sometimes blacks out
    By Thomza in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 7th January 2013, 16:57
  2. Replies: 4
    Last Post: 18th August 2012, 08:58
  3. Replies: 17
    Last Post: 16th August 2012, 10:07
  4. PLEEEEASE HELP - traction control light/power steering light on!!!
    By holdenvectra in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 28th June 2010, 23:39
  5. Fitted rear light,illuminated sunvisors and map reading light
    By glenboy in forum Vectra C / Signum Car Chat
    Replies: 26
    Last Post: 30th March 2008, 10:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •