User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Cruise control problem!

  1. #1
    Regular Member djr69uk's Avatar
    Join Date
    Feb 2008
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Cruise control problem!

    Before anyone suggests some of the usual things like clutch spring and indicator stalk... check this out...

    It only malfunctions when the temperature drops!!!

    It didn't work last winter, has worked brilliantly all summer and now it's started to play up again today - seeing as it's getting cold again. I guarantee it will work come spring lol!

    So what component is causing the cruise control to turn off - due to the temperature?!

    Does anyone have a schematic or full explanation of exactly how the CC works and what sensors etc... it relies on?

    Thanks

  2. #2
    Regular Member Marky's Avatar
    Join Date
    Jun 2006
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Could still be that the connectors at the bootom of the indicator stalk are dirty. The cold might make what connection there is left clean less effective.

    Also could your alternator be on its way out?? The only reason I say this is that my Cruise control in the last week has been playing up. Last night all the electrics went mental and it looks like the alternator has given up.

  3. #3
    Regular Member Brocks's Avatar
    Join Date
    Feb 2006
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have the same issue from day 1 and VX said there was nothing wrong! April -Aug no probs, Sept-May it won't stay on.

  4. #4
    On a Sabbatical
    Join Date
    Oct 2009
    Location
    rhyl
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i have same problem i change stalk all was fine doing it again on old stalk where you push the on button i stuck a screw driver down there aa thin one it would work fine for a bit,the stalk is so easy to change just pull on it and it comes out push new one in and thats it no stripping the cowling,i always found the top button was worse than the bottom

  5. #5
    Regular Member Marky's Avatar
    Join Date
    Jun 2006
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have had cruise control problems in the past and I have fixed it by cleaning the contacts at the bottom of the stalk.

  6. #6
    Regular Member djr69uk's Avatar
    Join Date
    Feb 2008
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Brocks View Post
    I have the same issue from day 1 and VX said there was nothing wrong! April -Aug no probs, Sept-May it won't stay on.
    is your under warranty still? we have identical cruise control problems. mine isn't under warranty.

  7. #7
    Regular Member djr69uk's Avatar
    Join Date
    Feb 2008
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Marky View Post
    I have had cruise control problems in the past and I have fixed it by cleaning the contacts at the bottom of the stalk.
    last year i cleaned the contacts and also swapped the stalk with a mates and still no improvement.

    i'd say the alternator is ok as don't have any other problems. the battery charges fine. last winter CC stopped working.. was fine in summer.. now not working again

  8. #8
    Regular Member
    Join Date
    Aug 2009
    Location
    Wakefield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As metal shrinks in cold weather, could it be something silly to do with the pedals as tapping the clutch or brake pedal will turn the cc off.... do these rely on sort of switch losing contact with the pedal to show they have been pressed and as such is the cold weather changing the distance such that the switch believes that the pedal has been depressed?

  9. #9
    Full Member Leemarksmith's Avatar
    Join Date
    Jun 2008
    Location
    Hanging Heaton / Batley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi (VXR Styling)

    Engine : Z19DTH (Re-mapped)

    Year : 04

    Mileage : 110k

    Default

    is this down to temp then in most cases...

    mine worked midday on motorway 9'c, then later this evening around 3'c it would not stay on, light just flick on then off?!?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cruise control problem
    By Bigtee in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 21st March 2012, 22:07
  2. Cruise Control Problem
    By gsi.vxr in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 1st May 2010, 13:16
  3. cruise control problem
    By Lee.. in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 2nd March 2009, 21:37
  4. cruise control problem
    By Herman in forum Electrical & ICE (including SatNav)
    Replies: 8
    Last Post: 12th December 2008, 19:10
  5. Cruise Control problem, HELP pls
    By Ridah in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 23rd October 2008, 11:06

Visitors found this page by searching for:

signum cruise control problem alternator

vectra c cruise control wont stay on

cruise control doesnt work cold weather

opel vectra c Sri cruise control wont stay on

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •