User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: wiper really ****** me off

  1. #1
    Regular Member
    Join Date
    May 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default wiper really ****** me off

    ok guys, had issues over the last month, my wipers started ennoying me with streaks and stuff during wiping, so i bought flat aero ones from ebay which was supposed to be great, i got them thru but the driver side wasnt doing its job properly so they sent me another one, this was perfect for about 5 days and it started getting really streaky again.
    so i thought the wipers might just be rubbish, so i bought normal wipers with spoiler from my local shop for £18, the passenger side seams fine with all of the blades but the new wipers make a horrible grubbing noise when going back down and dont seem to be wiping the window properly when going back down but is fine going up..

    im loosing my patience with it, any ideas with the problem lads?

  2. #2
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    has the arm been twisted so the blade isn't 90 deg to the screen and is it pulling in tight to the window

  3. #3
    Regular Member
    Join Date
    May 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    as far as i know nothing has been twisted...?

  4. #4
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    have you tried taking the wipers of and checking its not the linkage/motor

  5. #5
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What condition is the windscreen in?
    Once a year I usually apply a coat of rain-X
    I am getting near that stage again

  6. #6
    Regular Member
    Join Date
    May 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i tried washing the windscreen, and using glass polish too, makes no differance really..

  7. #7
    Regular Member Simo87's Avatar
    Join Date
    Jan 2008
    Location
    Middle Wallop
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    try rubbing the blade down with some vinegar on a rag as grease built up on the blade can cause streaks

    Simo

  8. #8
    Regular Member
    Join Date
    May 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ive only had them since yesterday.. uch im fed up

  9. #9
    Regular Member
    Join Date
    May 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    is it possible that the spring might be ragged? i dunno wat else to think..

  10. #10
    Regular Member
    Join Date
    May 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i should also mention the wiper clicks every time it goes to wipe. its been doing that for a good long time now.. dunno if that means anything?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wiper nut
    By dilan in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 25th November 2012, 00:12
  2. wiper arm
    By ian1401 in forum Bodywork & Interior
    Replies: 6
    Last Post: 28th March 2012, 14:42
  3. Wiper Linkage - failed O/S Wiper
    By silver-tongue in forum Engine & Drivetrain
    Replies: 7
    Last Post: 15th February 2011, 10:29
  4. FLAT FUSION WIPER BLADES KYODO WIPER BLADES Dynamic Flexi Wiper Blades
    By korlinski in forum Vectra C / Signum Car Chat
    Replies: 23
    Last Post: 25th June 2007, 19:40

Visitors found this page by searching for:

wiperreally

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •