User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Help needed CDTI 150

  1. #1
    Regular Member parsco's Avatar
    Join Date
    Sep 2008
    Location
    Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Thumbs down Help needed CDTI 150

    Help please guys. Just started the motor this morning and there is a load ticking noise as if something is caught somewhere tapping/ticking. Popped the bonnet and it sounds like it's coming from the belts but not sure. It goes away when you use the throttle...

    If that wasn't bad enough my swirl bar is not connected and just lying on its side is that the end of it (do I need to fork out for the dreaded inlet manifold) or can I just pop it back on?

  2. #2
    Regular Member nokiaman1978's Avatar
    Join Date
    Sep 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    any lights on the dash

  3. #3
    Regular Member parsco's Avatar
    Join Date
    Sep 2008
    Location
    Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by nokiaman1978 View Post
    any lights on the dash

    Not a thing mate. I haven't even noticed any 'limp' modes either. Don't have a clue how long the bar has been like that for?

  4. #4
    Regular Member Big Knox's Avatar
    Join Date
    Feb 2009
    Location
    Edinburgh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    there's a couple of cheaper fixes on here, not sure how long they last. Otherwise, it's a trip to the dealers for a new inlet which ain't cheap. However, if you haven't noticed any difference since it fell off, why worry about it?

  5. #5
    Regular Member
    Join Date
    Mar 2009
    Location
    darlo
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i have the ticking noise to have had it for abowt 6 month have had the belts and manifold changed in that time and still no better doest seem to have effected the perormance but its very anoying and the garage carnt seem to find out the problem

  6. #6
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    cdti's do sound like a bag of spanners on tickover, mine has always had the ticking/tapping on tickover, i hate it and would love to get rid of it, its the most crappy sounding engine on tickover ive ever had, everyone who hears it says it sounds s**t.

  7. #7
    Regular Member parsco's Avatar
    Join Date
    Sep 2008
    Location
    Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Big Knox View Post
    there's a couple of cheaper fixes on here, not sure how long they last. Otherwise, it's a trip to the dealers for a new inlet which ain't cheap. However, if you haven't noticed any difference since it fell off, why worry about it?

    So can I actually drive around with no swirl bar attached? If my inlet manifold is already beggared how can it make it any worse?

  8. #8
    Regular Member parsco's Avatar
    Join Date
    Sep 2008
    Location
    Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'm going to get a new inlet manifold and then get it fitted. Do I need to buy the actuator as well or will this still be working? (surely there would be lights on the dash if the actuator has failed?) Is there anything else that I will need to get to go with it? (I changed EGR recently)

    Thanks

  9. #9
    Regular Member parsco's Avatar
    Join Date
    Sep 2008
    Location
    Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Anybody??

  10. #10
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    you wont get a warning light till the car works out somethings wrong could be days might be worth fitting a actuator and rod then its all done. just intake manifold gasket and throttle body gasket. timing belt needs removing as diesel pump needs to come of so if coming sup oon for replacement might be worth changing.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Advice needed for my sri cdti 150
    By simmo3187 in forum Engine & Drivetrain
    Replies: 18
    Last Post: 3rd June 2011, 18:49
  2. Help Please needed on 1.9 cdti 150
    By Trist78 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 19th January 2011, 21:46

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •