User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Spanner/Car light

  1. #1
    Regular Member
    Join Date
    Feb 2009
    Location
    Stockton on Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Spanner/Car light

    My spanner through the car light keeps coming on when my 2.0 DTi Vec C is started first thing in the morning. I quickly switch it off then re start it and the light doesn't come on! Any ideas.

    The only thing that i could think of was is it a warning to change glow plugs??

    I'm probably wrong so any suggestions will be very welcomed.
    Thanks

    Steve

  2. #2
    Regular Member
    Join Date
    Oct 2009
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default hi mate

    hi mate how u doin it could b your due for a service maybe have u had any probs otherwise from that

  3. #3
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    think you could be right with the glow plugs as they are monitored and if one fails you will get warning first thing

  4. #4
    Regular Member jonnybravo's Avatar
    Join Date
    Jul 2009
    Location
    barnsley,yorkshire,GB
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum


    Engine : 20 Dti


    Default

    first job ss is to get your fault codes read

  5. #5
    Regular Member jonnybravo's Avatar
    Join Date
    Jul 2009
    Location
    barnsley,yorkshire,GB
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum


    Engine : 20 Dti


    Default

    press milage zero button with ignition off you will see what milage is left for service.

  6. #6
    On a Sabbatical
    Join Date
    May 2008
    Location
    Derbyshire (south)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If you're due a service this warning light will come one at the turn of the ignition, also when you turn off also, but the service light is in the shape of an oil can. The spanner through the car is a fault showing, so yes it needs to be read, not Probable the glow plugs, could be anything, but if it goes off after a seoned turn & stays off, its a minor problem.
    Try running it with the light on and see if it goes into limp mode??

  7. #7
    Regular Member
    Join Date
    Feb 2009
    Location
    Stockton on Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It don't need a service and its just had codes read about 2 weeks ago. The machine was ****** wrong as it cost me £50 for a sensor that it never needed as the EGR valve and other parts where covered in smeg. Cleaned up cleared codes and job was a good one.
    It only does it early on a morning when its been cooler over the last few days. This is the reason i think it could be glow plugs. Just wasn't sure if they where monitored. Anyone had a code for faulty glow plugs. Thanks for replies.

  8. #8
    New Member
    Join Date
    Nov 2008
    Location
    Buckinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Spanner Light

    I had the very same problem with an 04 plate DTi. Spanner light on first thing in the morning, wouldgo off after a minute or so and then wouldn't show again duirng the day. Tried lots of things - but it was the glow plugs

  9. #9
    Regular Member
    Join Date
    Feb 2009
    Location
    Stockton on Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks john. Mine hasn't done it for last 2 days but i've not been up at 5 in morning and its been pretty mild by mid morning. I'll keep an eye on it and maybe get them replaced. Do you replace all plugs or just the failed plug?? Thanks

  10. #10
    New Member
    Join Date
    Oct 2009
    Location
    Worksop
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Having just bought a Vectra cdti sri 150bhp 56 plate, I too got this problem first thing in the morning the car and spanner light would come on and go out after a couple of Minutes of driving.Would not come back on again rest of the day.Just fitted four new glow plugs and started from cold fault gone perfect very happy,noticed one of the plugs was rather black compared to rest so not doing its job.Very easy DIY on 16v engine with a long reach 9mm socket....First Post
    Last edited by topcat850; 2nd November 2009 at 14:03.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Problems with Air bag light, ABS, Anti Skid & Spanner light
    By WeDesign in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th December 2012, 21:23
  3. Should I Have A Spanner Light aswell as an Engine Light on My Signum?
    By StreetDragster in forum Engine & Drivetrain
    Replies: 16
    Last Post: 18th August 2012, 11:57
  4. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  5. spanner light then engine management light
    By learoy69 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 12th March 2010, 20:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •