User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Spanner Light, Throttle Body

  1. #1
    Regular Member
    Join Date
    Apr 2008
    Location
    High Wycombe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Insignia

    Trim : SRI NAV

    Engine : 2.0 CDTI 140

    Year : 2013

    Mileage : 20000

    Default Spanner Light, Throttle Body

    Hi All,

    Had the spanner come up and no revs above 2K on the way to work today. So pulled over and switched the engine off and back on again. The light came on, but off when running and all good for the remainder of the journey.

    I popped it into a Vauxhall garage and they've said its the Throttle Body. They've quoted just over £300 to fit a new one. Not sure if this is a good price?

    They've cleared the error and my trip home was un-interupted. I gave it a good run to try and clear any crud in the system.

    My question,

    Is there anything I can use to try and clear this and stop it happening again?

    Either clean it via something like Wynns EGR3, or 10K Boost De-Coke, or dis-mantle and clean, or am I going to have to just pay up.

    I've got a Signum 1.9CDTi 150, with about 75K miles,

    Any help would be great, cheers.

  2. #2
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    what year? early models did have throttle body issues but most were caught by warranty or net Q. it was a circuit problem so cleaning might not help

  3. #3
    Regular Member
    Join Date
    Apr 2008
    Location
    High Wycombe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Insignia

    Trim : SRI NAV

    Engine : 2.0 CDTI 140

    Year : 2013

    Mileage : 20000

    Default

    Its a 2005 55 plate.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Spanner Light After Cleaning EGR & Throttle Body
    By john506 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 5th September 2011, 18:53
  2. Spanner Light after Cleaning Throttle Body
    By john506 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 28th May 2011, 20:30
  3. Oil in Throttle Body 3.2v6
    By pigeon142 in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 24th January 2010, 21:41
  4. Arrrr!Throttle my Throttle Body!
    By boze in forum Engine & Drivetrain
    Replies: 9
    Last Post: 12th September 2009, 11:15
  5. 3.2 throttle body
    By poves in forum How much is it worth? (THIS SECTION IS NOW CLOSED)
    Replies: 3
    Last Post: 15th December 2008, 10:16

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •