User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: CD70 Navi GPS has died?

  1. #1
    New Member
    Join Date
    Oct 2009
    Location
    Stevenage
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default CD70 Navi GPS has died?

    Hi guys,

    My first posting here, hope you guys can help. I have a 2006 Signum and yesterday the GPS stopped working on my CD70 Navi system.
    Typically it was ten miles away from the destination and i rely far too much on Sat Nav!

    Anyway, the system all works but when starting up I get a message saying "Navi is initialising" which then disappears and then the screen display has a cross through GPS. When the car is out side my house the sat nav thinks it is in a field 70 miles away!

    Any one got any hints or is it a new CD70 unit for me?

    Cheers
    Vince

  2. #2
    Regular Member
    Join Date
    Mar 2007
    Location
    North East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Could be the gps receiver is faulty. Might be worth getting one from ebay as they are pretty cheap and trying it.
    Last edited by rockh; 28th October 2009 at 17:00. Reason: dodgy typing

  3. #3
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Problem is a faulty aerial signal amplifier or poor signal ...replace aerial base, or check connections also check aerial mast isn't broken...

    Remember sat nav receiver is like a radio receiver...needs to get good signals to work well.

  4. #4
    New Member
    Join Date
    Oct 2009
    Location
    Stevenage
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for your replies. have checked the connections and all seem okay. I have ordered a new GPS reciever as per rockh's suggestion so will let you know if that works!

    Cheers

    Vince

  5. #5
    New Member
    Join Date
    Oct 2009
    Location
    Stevenage
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ah well, it was worth a shot! Got the new GPS antenna, plugged it in but the GPS symbol still shows as crossed out after the "Navi is initialising" message comes up so it must be a problem with the unit itself? Is there a way of resetting the unit? Does this mean a trip to the dealer for me?

  6. #6
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have a look here matey: http://www.vectra-c.com/forum/showth...ght=cd70+reset

    Try a reset... mine was out by about 100 meters & resetting cured it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help !! CD70 working but Navi has died ??
    By Dre in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 14th April 2011, 17:43
  2. CD70 Navi
    By tammyman09 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 14th September 2009, 21:17
  3. CD70 navi help
    By bigbeech in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 31st July 2008, 10:47

Visitors found this page by searching for:

cd70 navi reset

gps on navi cd70 not workin why

where gps on cd70 navi

gps cd70 navi

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •