User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Abs & tc lights on

  1. #1
    Regular Member
    Join Date
    Aug 2009
    Location
    ayrshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Abs & tc lights on

    Hi hope someone can help me here as of sunday both the ABS and TC lights have come on I have a Vectra sxi 2.0 dti 03 I had the front discs and pads changed only 9 days ago. Dont know if that might have anything to do with this or not I was thinking maybe the sensors hae become dirty as a result in the pads wearing in from the dust. I,m not sure where the sensors are or how easy they are to locate. One other thing I should mention is when the car is sitting at standstill I could drive of to the right without the lights coming on as soon as I turn the wheel to the left this is when they come on even at standstill. Hopefully someone can shed some light on this.
    Regards to all in advance.

  2. #2
    Forum Moderator John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like one of the ABS sensor cables has a nick in it and is shorting out when you turn left

  3. #3
    Regular Member
    Join Date
    Jul 2009
    Location
    lanark
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    sounds like a bad connection on a abs wire bud,

    they run down the strut, across the hub and into the hub bearing.

    check for twists, chaffes, and bad connectons

  4. #4
    Regular Member
    Join Date
    Aug 2009
    Location
    ayrshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Cheers how easy or difficult are they to replace

  5. #5
    Moderator & Events Assistant paulhb's Avatar
    Join Date
    Dec 2007
    Location
    Wondering lonely as a cloud
    Post Thanks / Like
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)

    Default

    Too much of a coincidence following from the disc and pad change probably got a wire not reinstalled right that is shorting out probably just needs relocating and self almalgamating tape being put over the damaged area as the lights are not constant but check soon before the cable is completely goosed.

  6. #6
    Regular Member
    Join Date
    Aug 2009
    Location
    ayrshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I have had a look after taking wheel of and had noticed a very thin black cable which was broken of from somewhere I had assumed this was the pad wear sensor cable but not ery sure what i,m looking for. would I need to take discs of to locate the sensor and to change or should I take it back to the dealer who may then charge me an arm and a leg for something that could have been caused by the fitting of the discs and pads.

  7. #7
    Regular Member
    Join Date
    Aug 2009
    Location
    ayrshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Attachment 26142 is this the sensor cable here circled

  8. #8
    Forum Moderator John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yeah thats the abs sensor cable at worst you'll need a new wheel bearing as they are one unit

  9. #9
    Regular Member
    Join Date
    Aug 2009
    Location
    ayrshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks I will give it a check in the morning but nothing I could see earlier when I had the wheel of

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Brighter Lights for side lights, Vectra SRI150
    By 150_SRI in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 13th July 2011, 23:50
  2. Replies: 2
    Last Post: 31st March 2010, 13:30
  3. Philips bluevision h7 head lights & side lights brand new
    By davidlewis24 in forum Parts for sale
    Replies: 2
    Last Post: 19th March 2009, 22:42
  4. Dark lights and Rear Lexus lights finally fitted
    By Leviathan in forum Styling
    Replies: 32
    Last Post: 29th February 2008, 22:35

Visitors found this page by searching for:

vauxhall vectra abs light on after disk and pad change

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •