User Tag List

Thanks Thanks:  0
Likes Likes:  1
Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: 2.0t turbo fault code P0034

  1. #21
    Regular Member KitS's Avatar
    Join Date
    May 2016
    Location
    Lydney Glos
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum x 2

    Trim : Design & Elite

    Engine : 2.0 T & 2.8 V6 Turbo

    Year : 2004

    Mileage : 144444

    Default

    Hmmmm, perhaps I'll follow the oil change and flush routine then.

    My previous LPG Zafira seemed to run for ever without need for an oil change, but then it had the blasted belts instead of chains.

  2. #22
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Post Thanks / Like
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2t

    Trim : standard

    Engine : z20net

    Year : 08

    Mileage : 32000

    Default

    Im sure its already been mentioned here but why not run and engine flush through it and do an oil change now?..it might help with the chains..or it might not.Cheap enough to do.

  3. #23
    Regular Member KitS's Avatar
    Join Date
    May 2016
    Location
    Lydney Glos
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum x 2

    Trim : Design & Elite

    Engine : 2.0 T & 2.8 V6 Turbo

    Year : 2004

    Mileage : 144444

    Default

    I'm going to do exactly that, yes.

  4. #24
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Elite

    Engine : 1.6T SIDI Petrol

    Year : 2014

    Default

    Quote Originally Posted by KitS View Post
    I'm going to do exactly that, yes.
    any better after the flush and oil change?

  5. #25
    Regular Member KitS's Avatar
    Join Date
    May 2016
    Location
    Lydney Glos
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum x 2

    Trim : Design & Elite

    Engine : 2.0 T & 2.8 V6 Turbo

    Year : 2004

    Mileage : 144444

    Default

    Sorry, I should have posted about that.

    Yes, it's much improved, all the thrashing and slight rattling have vanished like a thief in the night, great tip, thanks.

    The turbo seems to have solved itself as it's working 99.9% of the time, and even a duff foglight bulb seems to have fixed itself too, I'm suitably flabbergasted.

  6. #26
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Post Thanks / Like
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2t

    Trim : standard

    Engine : z20net

    Year : 08

    Mileage : 32000

    Default

    Pleased the flush and oil change helped. I dont do the miles I used to but still maintain a regular flush and oil/filter change.

  7. #27
    New Member Dee-77's Avatar
    Join Date
    Oct 2016
    Location
    Northern Ireland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri nav xp

    Engine : 2.0 turbo sri

    Year : 2007

    Default

    Hi sorry to restart old thread, I have vectra c Z20net engine and have got round to looking at my turbo problem as I have same code as yourself but only to find the by pass valve near throttle body has been tampered with as the hose coming from the top of it is of from wherever it’s supposed to go and a screw has been put in the end of it, I’m baffled but I can’t get any diagrams to show me where it’s supposed to go and again sorry for restarting old thread, thanks Dee

  8. #28
    Midlands - Head case Organiser Dog_Book's Avatar
    Join Date
    Oct 2013
    Location
    Derby
    Post Thanks / Like
    Mentioned
    277 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : VXR

    Engine : Z28NEH

    Year : 07

    Default

    Don’t apologise for bringing up an old thread at least you bothered to search that’s why we post things so others can see what we did, just a shame the OP and mods didn’t post in the engine section
    Vectra VXR estate 2007 Sapphire Black
    Teapot Tuned 245/300
    Eibachs B8's, fully loaded factory options

    Tech2 & MDI diagnostics

  9. #29
    New Member Dee-77's Avatar
    Join Date
    Oct 2016
    Location
    Northern Ireland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri nav xp

    Engine : 2.0 turbo sri

    Year : 2007

    Default

    Cheers mate, I’m not to familiar on how to start new threads so thought I would try this way.

  10. #30
    Full Member
    Join Date
    Nov 2019
    Location
    Moray
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design T

    Engine : 2.0

    Year : 2004

    Default

    Sorry to drag up and old thread again.
    New to the forum with a Signum 2.0i

    Got the same fault code on mine, is it best to just replace both valves and retest?

    Has anyone got a diagram of which pipes go where from the valves too? Had a good search through the forum but I'm totally new to Vauxhalls after having a fiesta and and Mx5

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. P0034
    By tda1610 in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 12th February 2013, 22:38
  2. Fault code help!
    By joee91 in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 13th July 2012, 00:52
  3. Fault code P0243 (1.9CDTI 150) Turbo wastegate...
    By danBoy in forum Engine & Drivetrain
    Replies: 9
    Last Post: 4th December 2010, 15:45
  4. help with a fault code
    By jan65uk in forum Engine & Drivetrain
    Replies: 1
    Last Post: 15th December 2009, 20:57
  5. Help with fault code,
    By robwilson69 in forum Suspension, Wheels & Brakes
    Replies: 17
    Last Post: 13th December 2009, 21:57

Visitors found this page by searching for:

vectra 2.0 turbo 0034 code

code P 0034

https:www.vectra-c.comforumshowthread.php93947-2-0t-turbo-fault-code-P0034

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •