User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: vectra c 2.2 wont start any ideas ??

  1. #1
    New Member
    Join Date
    May 2009
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default vectra c 2.2 wont start any ideas ??

    I have just replaced a 2.2 z22se engine in a 52 plate vectra c, the donor engine came from a vectra b, i used most of the parts from the vectra c on the donor engine, when i had finished i fired her up and started first time no problem, i had it up in the air on axle stands so i left it running at 1400 rpm for about an hour to check for leaks etc(as i had replaced all of the timing chain gear) it was fine then it made a rumble/rattle and cut out.
    when i went to re start it, i got nothing, just a click from a relay in the footwell (passenger side) and the fuel relay in the boot is clicking constantly like a hazard light relay. I have connected the code reader but it is now telling me it cannot establish a link to the ecu and the engine management light on the dash will not light up even when the ignition is just turned on. i did not change the knock sensor oil pressur/level switch or anything else that was bolted into the head or block
    There is plenty of fuel
    battery is fully charged
    oil is at max
    engine will turn freely by hand and also if i feed a live directly to the starter it turns over great.
    I haven't changed the knock sensor temp sensor, or any sensors bolted into the block they are all from the vectra b
    i have given a lot of info here and if anyone can give me the solution to this i will gladly make a generous donation to them, if anyone is in the Lancashire area that would be able to sort it then i will pay whatever it costs, i refuse to take it to vauxhall !!!!!!
    please help i am close to suicide with it :-)

  2. #2
    On a Sabbatical
    Join Date
    Oct 2009
    Location
    rhyl
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    could it be sum sort of imobiliser

  3. #3
    New Member
    Join Date
    May 2009
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i have reprogrammed the key, and i am told that even if the immobiliser is faulty the car will still crank but not fire, i dont know how true this is

  4. #4
    On a Sabbatical
    Join Date
    Oct 2009
    Location
    rhyl
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    if it was immobiliser you would have a picture of a lock in the dash display

  5. #5
    Regular Member Dose's Avatar
    Join Date
    Aug 2008
    Location
    Falkirk/dunfermline/alloa
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check for leaks etc(as i had replaced all of the timing chain gear) it was fine then it made a rumble/rattle and cut out.
    i wouldnt think it would be an imobiliser fault if it ran then cut out.. I would be more inclined to check the timing gear if it rattled...with you mentioning you replaced the chains etc.
    also check the cam position sensor is secure and not came loose and got damaged(rattle)

  6. #6
    New Member
    Join Date
    May 2009
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi Dose, if the timing chain had jumped a bit the engine would still crank i would have thought, i will check the cp sensor i didnt think of that one, the engine turns freely if i supply a direct feed to the starter, would an immobiliser fault stop it cranking over

  7. #7
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    I remember a thread on a DTi direct conversion where certain parts of the original engine like the fuel pump had to be put on the new engine just because on immobiliser issues as they are linked/locked to the car.

  8. #8
    Regular Member Dose's Avatar
    Join Date
    Aug 2008
    Location
    Falkirk/dunfermline/alloa
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by john2666 View Post
    Hi Dose, if the timing chain had jumped a bit the engine would still crank i would have thought, i will check the cp sensor i didnt think of that one, the engine turns freely if i supply a direct feed to the starter, would an immobiliser fault stop it cranking over

    sorry mate didnt read that right:S

    with an ammobiliser fault it should still crank over..i gather all earths have been checked?power cables?

  9. #9
    New Member
    Join Date
    May 2009
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thats an interesting one about the fuel pump, the fuel relays is clicking its ar*e off, it is pumping through to the injectors though, and the engine was running after i had fitted it for about an hour

  10. #10
    Regular Member Telly Addict's Avatar
    Join Date
    Sep 2009
    Location
    Fife
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW e92 335d

    Trim : M Sport

    Engine : 3.0 TT

    Year : 2008

    Default

    This is what my Veccy is now doing, did anyone discover what was responsible?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra c 2.2 dti wont start
    By latif in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 27th January 2013, 07:06
  2. battery drained and now wont start..ideas?
    By dahmich in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 6th April 2012, 07:34
  3. vectra c 2 dti wont start
    By ricky192 in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 28th December 2009, 23:50
  4. vectra wont start
    By damien whiley in forum Engine & Drivetrain
    Replies: 2
    Last Post: 6th May 2009, 17:30
  5. my vectra wont start help please
    By raymond1711 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 14th April 2008, 13:04

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •