User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: 2.2 Petrol Not Starting PLEASE HELP!

  1. #1
    Regular Member
    Join Date
    May 2009
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused 2.2 Petrol Not Starting PLEASE HELP!

    Hi I have a 2.2 pertrol vectra c, about 2 weeks ago i put the key in turned it and nothing, didn't even crank over, mil light was flashing, took the key out put it back in and it started first time. It is now doing this consistently some days it won't start all day other days it starts first time. A cowboy mechanic told me that it was the key but the same happens with the spare, he then told me to change the battery but surely thats just for the central locking. Any ideas please help

  2. #2
    Regular Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mil light...?

  3. #3
    Regular Member
    Join Date
    May 2009
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    MIL - Malfunction Indicator Light, orange car with spanner in it comes on usually when ya start the car, i think its the same as engine management or similar

  4. #4
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by lfcfan85 View Post
    Hi I have a 2.2 pertrol vectra c, about 2 weeks ago i put the key in turned it and nothing, didn't even crank over, mil light was flashing, took the key out put it back in and it started first time. It is now doing this consistently some days it won't start all day other days it starts first time.
    The flashing car/spanner light is telling you there is an immobiliser related fault. You'll need to get the fault code(s) read out as this takes away the guesswork.


    Quote Originally Posted by lfcfan85 View Post
    A cowboy mechanic told me that it was the key but the same happens with the spare, he then told me to change the battery but surely thats just for the central locking.
    Correct. The battery in the fob is for the central locking only.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. petrol/lpg cold starting
    By murt690 in forum Engine & Drivetrain
    Replies: 20
    Last Post: 4th February 2013, 21:52
  2. Signum starting trouble and smell of petrol!
    By iam2103 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 9th May 2012, 18:32
  3. Problems starting 2.2 petrol in cold
    By phil_l875 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 20th December 2010, 13:45
  4. 1.8 Petrol engine starting problems
    By Rallyingden in forum Engine & Drivetrain
    Replies: 7
    Last Post: 8th September 2010, 09:35
  5. 2.2 petrol starting problem
    By Johny Tango in forum Engine & Drivetrain
    Replies: 4
    Last Post: 30th December 2007, 19:17

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •