User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: MOT Failure - Offside Handbrake

  1. #1
    Regular Member
    Join Date
    May 2008
    Location
    Scottish Highlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default MOT Failure - Offside Handbrake

    Ok my SRI 2.0T went for MOT today and failed.....14% efficiency on the offside handbrake. Now Arnold Clark decided to check it and I authorised a repair...

    The handbrake was stuck on in the forward position on caliper.....so new one ordered.....wrong one....another one ordered ....wrong one.....so in their wisdom and to try gettin me home....Arnold Clark put the old one back on and it's now seized completely!!! Wheel won't budge!!!!!!! So can't drive car

    Then they wouldn't give me a courtesy car and offered me a hire car for £22 for the day!! The day!!!

    I have been in there since 11.30 this morning for an MOT and left at 1820!!! with no car.

    Anyone know if they are takin the mick as the bloke is saying he can't free it up...even though the car drove their fine this morning.

    I say they are liable

    Allan

  2. #2
    Regular Member clightowler's Avatar
    Join Date
    Oct 2007
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI hatch

    Engine : z19dth

    Year : 2006

    Mileage : 110000

    Default

    Hi mate, mine failed with exactly same problem (even the 14% efficiency on o/s) , turned out was just the cable that was too tight, (if caliper was jammed then the pad would be permanantly on with footbrake as well.) you need to get them to try resetting the handbrake cable from the lever end, it a bit of a faff as the rear centre console needs to come out to get to it but resetting is easy, u just let the handbrake off then push the rod (i'd by white plastic cap and spring around it) back in using the lock bar to hold it, then once brakes wheels etc back together and pads pumped up by foot brake you just operate the lever a few times. Have you had new rear pads or disks fitted recently btw cos that what caused mine?
    Last edited by clightowler; 13th October 2009 at 15:56.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 41
    Last Post: 6th September 2012, 20:38
  2. handbrake failure!!!
    By ilaing in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 10th May 2008, 17:44
  3. Handbrake Failure
    By Ben H in forum Vectra C / Signum Car Chat
    Replies: 47
    Last Post: 16th October 2007, 16:49
  4. Handbrake failure - a known fault?
    By Ewormaharg in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 26th June 2007, 23:44
  5. Handbrake failure
    By Sparkyvxr in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 16th April 2006, 20:18

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •