User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: knocking from front strut???

  1. #1
    Regular Member
    Join Date
    Sep 2009
    Location
    campbeltown argyll
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    rolleyes knocking from front strut???

    i have noticed a slight kinda knocking noice from what seems like the passenger side strut,

    not really noticable when driving just when moving wheel when car is parked.

    anyone think/know what it could be??

    cheers

  2. #2
    Regular Member Cossy's Avatar
    Join Date
    Dec 2008
    Location
    East Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Maybe the anti-roll bar, i had a similar sound and that sorted it, only cost £15 for 2.

  3. #3
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    sounds like either the drop link bar has had it or as cossy mentioned the anti roll bar bushes are knackered but id check to see if everything under there is tight
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  4. #4
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    spring movement in mount - if recently changed or ......












    broken

    0-Large smile ......every time it's driven

  5. #5
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    Quote Originally Posted by deztroyer View Post
    spring movement in mount - if recently changed or ......












    broken
    opps forgot about the dreaded snapped springs lol
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  6. #6
    Regular Member
    Join Date
    Sep 2009
    Location
    campbeltown argyll
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    new springs fitted before i bought car!!!

  7. #7
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    might not be seated properly
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  8. #8
    Ex Vec-C Admin & Founder GARY3306's Avatar
    Join Date
    Jun 2005
    Location
    Ashington, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I would hazard a guess at the drop link myself, but as said above, check the strut top mount is fully tightened. Jack the car up and put a bar under the tyre then lever up. Lots of play at the top shouldnt be there
    [SIGPIC]VX<font color=Red>R</font> with added Courtenay <img src=https://www.vectra-c.com/forum/images/smilies/biggrin.png border=0 alt= title=Big Grin class=inlineimg />

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. replacing front strut
    By rae287 in forum Suspension, Wheels & Brakes
    Replies: 4
    Last Post: 14th November 2012, 17:37
  2. Front strut top mounts have gone
    By Derek Mc in forum Handling & Braking
    Replies: 6
    Last Post: 8th August 2012, 20:18
  3. Front strut help
    By jodiexii in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 9th July 2012, 09:23
  4. Bearings on front strut
    By LITTLEBOYRED in forum Suspension, Wheels & Brakes
    Replies: 4
    Last Post: 6th February 2009, 23:47

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •