User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Help/Advice needed BK999 19" alloys

  1. #1
    Regular Member braveheart's Avatar
    Join Date
    Jul 2009
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Help/Advice needed BK999 19" alloys

    Around a month ago i had a flat on the journey home on the M6, i'd say i drove for around 1-2 miles before realising what was wrong and pulling over. I've had both front tyres replaced as a result as the other was on the way out too.
    Since then i've been having serious problems with the steering wheel shaking and the car wobbling at certain speeds. I've had the alignment done and the wheels balanced to within 0g which did improve it slightly but still as soon as i hit 60 it starts shaking and it is really bothering me as you can imagine.
    Before all this the ride was very smooth so i'm wondering what could be causing this problem. I'm unaware if i had spigot rings originally and they have possibly not been re-installed, or indeed if i even need spigot rings with these alloys.
    If anyone could possibly give me any advice on whether spigot rings would be necessary and what size i would need i'd appreciate it, as i'd rather try installing them first. I'd rather need spigot rings than to find out that my wheel may have buckled when i had the flat.
    Cheers.

  2. #2
    Regular Member TomiboyC's Avatar
    Join Date
    Aug 2007
    Location
    East Ayrshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Had mine off last week to change the pads and i definately have spigot rings on mine mate.

  3. #3
    Regular Member TomiboyC's Avatar
    Join Date
    Aug 2007
    Location
    East Ayrshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sorry mate just noticed you said 19", mine are 18" so my previous post is no use to you at all!!!

  4. #4
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Didn't realise they did the BK999's in 19", only 18"..?

  5. #5
    Regular Member
    Join Date
    Oct 2007
    Location
    Shropshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If you don't have sipgot rings the wheel may not centre properly on the hub. Take the wheel off and put it back on, tightening each bolt about 1/4 at a time and doing opposites and it should centre the best it can without a sipgot ring.

  6. #6
    Regular Member braveheart's Avatar
    Join Date
    Jul 2009
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers Tomiboy the fact that you have spigots on yours would probably indicate that i would need them too.

    Dan, here's a link to them on the bay http://cgi.ebay.co.uk/BK999-8x19-All...d=p3286.c0.m14

    Cheers for the advice mucklestone i might give that a bash until i can get some spigot rings.


    Are the 19" BK999's genuine Vauxhall wheels or third party as i believe they are an optional extra on the VXR?
    Would anyone be able to give me the measurements for the correct spigot ring size?

  7. #7
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Sorry to hijack but could you post a couple of pics? I'd like to see them

  8. #8
    Regular Member braveheart's Avatar
    Join Date
    Jul 2009
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by john.robertson2 View Post
    Sorry to hijack but could you post a couple of pics? I'd like to see them
    It's a bit dirty tbh but aye i'll get some pics in a bit

  9. #9
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Wow, never knew they did them in 19".... oh no.... my Mrs aint gonna be happy with me

  10. #10
    Regular Member braveheart's Avatar
    Join Date
    Jul 2009
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by john.robertson2 View Post
    Sorry to hijack but could you post a couple of pics? I'd like to see them
    Here they are mate, just took some quickly. Not been washed for a couple of weeks so i'll take some more next time i make it nice and shiny






Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New alloys, 18" BK999
    By gaz__1984 in forum Styling
    Replies: 12
    Last Post: 20th January 2013, 21:23
  2. Bk999 18" Alloys
    By robdd1 in forum Handling & Braking
    Replies: 11
    Last Post: 3rd January 2011, 14:22
  3. Bk999 advice needed
    By davidlewis24 in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 3rd January 2010, 13:11
  4. Alloys & Lowering Help / Advice Needed Please Folks
    By pjjohnst in forum Handling & Braking
    Replies: 14
    Last Post: 21st January 2009, 19:34

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •