User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Power steering problem

  1. #1
    New Member
    Join Date
    Jul 2009
    Location
    gloucester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry Power steering problem

    I have a 2.2 elegance and I have a problem with the power steering,the warning light has come on and the steering gets light at high speed,have had it on a diagnostic and nothing came up, is ther a speed sensor?
    has any one had this problem
    Steve

  2. #2
    Regular Member old cruiser's Avatar
    Join Date
    Jun 2008
    Location
    slough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you checked the power steering fluid level?
    Cheers Pete

  3. #3
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    these pumps are electronicly run, and if the fluid level is ok, then it might be the pump or the cim

  4. #4
    New Member
    Join Date
    Jul 2009
    Location
    gloucester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Fluid level is ok,What's a cim

  5. #5
    Regular Member
    Join Date
    Feb 2009
    Location
    asdasd
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This happens to mine..Had a new pump fitted (2nd hand one) after my one failed..Mine goes Hard when i do manoeuvre (dont how to spell it).Light comes up on diagnostics clear codes nothing happens..

  6. #6
    Regular Member garvey's Avatar
    Join Date
    Feb 2008
    Location
    Co Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had light come on with faulty sensor.

  7. #7
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by scooter boy View Post
    Fluid level is ok,What's a cim
    Part of the cars canbus
    Now I need a turbo to keep up!

  8. #8
    Regular Member Stuarty's Avatar
    Join Date
    Dec 2007
    Location
    Aberdeenshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I sarted up the vec today and i had a warning light of a steering wheel with an exclamation mark through it so tried to turn the steering wheel and had no power steering turned the car off and on again and all seems fine now hope theres not a serious problem lurking round the corner!!

  9. #9
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by Stuarty View Post
    I sarted up the vec today and i had a warning light of a steering wheel with an exclamation mark through it so tried to turn the steering wheel and had no power steering turned the car off and on again and all seems fine now hope theres not a serious problem lurking round the corner!!
    Did you try revving the engine to see if the PAS would start working? If the battery voltage is too low then it can affect the PAS as it uses an electric pump.

  10. #10
    Regular Member Stuarty's Avatar
    Join Date
    Dec 2007
    Location
    Aberdeenshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No i didnt try revving the engine il try that if it happens again.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Power steering problem
    By Danwells72 in forum Vectra C / Signum Troubleshooting
    Replies: 15
    Last Post: 9th October 2012, 16:25
  2. On Going power steering problem
    By gazspeight in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 29th November 2011, 18:18
  3. power steering problem
    By mr.d in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 9th August 2011, 22:33
  4. Power Steering Problem
    By llaregub in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 3rd January 2008, 11:35
  5. Power Steering problem
    By H11LGX in forum Suspension, Wheels & Brakes
    Replies: 8
    Last Post: 22nd March 2006, 01:19

Visitors found this page by searching for:

opel vectra c 2.2 elegance power steering

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •