User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: turbo prob??

  1. #1
    Regular Member Deacon's Avatar
    Join Date
    May 2007
    Location
    weston-super-mare
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default turbo prob??

    hi people, need your help im lost, lol

    i have a 1.9 cdti 120bhp

    basically was driving my car monday went to put my foot down, heard a POP and the turbo whistle is now really loud,

    have checked all the hoses, etc, nothing is loss or leaking,

    it did sound like it could be that, maybe in not lookin in the right place.

    could it be the ball bearing in the turbo gone or maybe even a fin off the turbin

    i dont wanna drive it just incase i do more damage, and its doing my head in lol

    any help or advice will be great thank u

  2. #2
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it sounds like you need to have a good luck round maybe look at the inter cooler has poped

  3. #3
    Regular Member sri andy's Avatar
    Join Date
    Apr 2009
    Location
    Lancs/Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default


  4. #4
    Regular Member Deacon's Avatar
    Join Date
    May 2007
    Location
    weston-super-mare
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    will that cause the turbo to whistle more and louder??

  5. #5
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeah it the same as a burst hose ..... have ya checked the lower intercooler hoses

  6. #6
    Regular Member vanquis1979's Avatar
    Join Date
    Mar 2008
    Location
    gainsborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    my mates 120 cdti is doing the same and he had a new turbo 6 weeks ago so you reckon bottom hoses?

  7. #7
    Regular Member Deacon's Avatar
    Join Date
    May 2007
    Location
    weston-super-mare
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i think i may have cracked the top incooler hose that runs to the inlet.
    now you have mentioned it.

  8. #8
    Regular Member vanquis1979's Avatar
    Join Date
    Mar 2008
    Location
    gainsborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Deacon View Post
    i think i may have cracked the top incooler hose that runs to the inlet.
    now you have mentioned it.
    is the power still there is it just a loud whistle when you nail it?

  9. #9
    Regular Member Deacon's Avatar
    Join Date
    May 2007
    Location
    weston-super-mare
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeah power is still there, just a louder whistle. why??

  10. #10
    Regular Member craigbarlow18's Avatar
    Join Date
    Aug 2008
    Location
    Staffordshire (used to be Newark) And Back to Newark again!!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i got this very sae problem and never been able to find out why

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. egr prob
    By landynigel in forum Engine & Drivetrain
    Replies: 7
    Last Post: 14th March 2012, 15:21
  2. 2.2 dti turbo prob?
    By chris1804 in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 23rd October 2009, 23:28
  3. ABS ecu prob
    By CBag7 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 5th September 2009, 13:12
  4. 2.2 sri prob
    By junior72 in forum Suspension, Wheels & Brakes
    Replies: 2
    Last Post: 15th August 2008, 22:37
  5. MPG Prob?
    By Basil in forum Vectra C / Signum Car Chat
    Replies: 16
    Last Post: 20th October 2005, 19:46

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •