User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Enginge problems- can you help with diagnosis?

  1. #1
    New Member
    Join Date
    Sep 2009
    Location
    oxford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Enginge problems- can you help with diagnosis?

    Hello all
    I bought a Signum estate 1.9 cdti yesterday, '54 plate and 66k on the clock. Lovely car and I was initially very pleased with how it was performing on the motorway. However I have since realised that when accelerating in 2nd/3rd from a little below 2000 revs to a bit above, the car judders, as though it is on the power, then coughing off, then a little more power, than backing off again. Any idea what this could be?
    The car comes up as a 150 on the insurance database, although I thought it was a 120. There is no red on the engine label on the back of the car!
    It is an enginge with a cam chain rather than a cam belt. I can find the engine number if this is any help.
    Thanks in advance
    George

  2. #2
    New Member
    Join Date
    Sep 2009
    Location
    oxford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ps- There was a slight engine whine when I took the car for a test drive before buying it, so the dealer replaced an alternator brush (whatever that is) before I picked it up, which fixed the noise. Could this be related?

  3. #3
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP NAV

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    Could be the usual EGR fault, this effects power around the 2k rev mark, can be cleaned for free and an hour of your time, or replaced for about £90.

    Where is your oil filler cap on your engine, if its on the right hand side (as you look at it) its a 150, the left a 120.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. diagnosis time
    By roverjay in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 4th December 2012, 12:05
  2. Engine Diagnosis
    By stevej in forum Troubleshooting
    Replies: 2
    Last Post: 14th August 2009, 10:46
  3. Fault Diagnosis
    By jamesworts in forum Troubleshooting
    Replies: 0
    Last Post: 6th August 2009, 21:36
  4. Diagnosis needed
    By Finty in forum Suspension, Wheels & Brakes
    Replies: 1
    Last Post: 5th April 2009, 19:33
  5. VX mis-diagnosis!!!!
    By Woodsta in forum Engine & Drivetrain
    Replies: 12
    Last Post: 8th February 2007, 22:39

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •