User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: CD30 problem

  1. #1
    Regular Member
    Join Date
    Aug 2008
    Location
    west lothian
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default CD30 problem

    hi guys,

    my 2005 vectra cd30 unit has started playing up.

    After the battery was disconected last week for 20min.

    Now when you remove the keys the radio turns off as it should

    I lock the car up, and with in 1 hour the radio has turned its self back on.

    I thought i was going mad the first time it happend, but it has done this three or four times now (but not every time I leave it parked up)

    Any help would be good, as some weekends I dont use the car which meens the radio could be on from friday night through to monday morning.

    thanks in advance

  2. #2
    Regular Member scott_150cdtisri's Avatar
    Join Date
    Jan 2006
    Location
    Crewe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    this kept happening on my first vectra (54 reg cd30) I took it to dealers saying it does it and appaerently its a known fault and they changed the head unit. my wifes company astra did the same too and flattened the battery once, you would go to you car sometimes and the stereo would be playing to itself!

  3. #3
    Regular Member
    Join Date
    Aug 2008
    Location
    west lothian
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by scott_150cdtisri View Post
    this kept happening on my first vectra (54 reg cd30) I took it to dealers saying it does it and appaerently its a known fault and they changed the head unit. my wifes company astra did the same too and flattened the battery once, you would go to you car sometimes and the stereo would be playing to itself!

    thanks for the reply,

    if its a known fault i wonder if they would change mine because it it a 2005 model and no longer under warreny

  4. #4
    Regular Member
    Join Date
    May 2008
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine does this to - it did it when I first bought the car and then I started leaving a CD in the unit and this seemed to cure it. I left it like that for the last year without using the CD and no problem. I then tried using the CD payer again the other day and now the problem is back. I dont fancy the bill for a new unit so im thinking of trying to put a switch in the power supply to the unit somewhere so I can isolate it when parked up - so long as I dont forget to flick the switch!

  5. #5
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    You should note that there are two reds to the display, and one to the head unit.

    If you put a switched supply in, then put this to the head unit supply...pin 15 I think (Big Fat Red wire)
    If the cars works as I think it should, then the display etc won't lose it's memory for the time etc.

    At worst the display may still illuminate after the hour (although I doubt this), but this uses less power than the head-unit, and so shouldn't flatten the battery as quickly.

  6. #6
    Regular Member
    Join Date
    Aug 2008
    Location
    west lothian
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Chilie View Post
    Mine does this to - it did it when I first bought the car and then I started leaving a CD in the unit and this seemed to cure it. I left it like that for the last year without using the CD and no problem. I then tried using the CD payer again the other day and now the problem is back. I dont fancy the bill for a new unit so im thinking of trying to put a switch in the power supply to the unit somewhere so I can isolate it when parked up - so long as I dont forget to flick the switch!

    You are right by the way I put a cd back in the unit and the fault has gone.

    I am waiting for a spare unit to strip down so I can check out the cd in sensor, I also have a circuit diagram for the unit.

    So I will fix it one way or another.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem with my CD30 stereo
    By e55ex_rob in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 8th December 2011, 13:09
  2. CD30 MP3 Problem
    By tolly in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 3rd May 2011, 17:51
  3. Cd30 problem
    By Ralphwells1967 in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 26th March 2010, 22:59
  4. CD30 Problem
    By toughmat in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 14th February 2010, 19:45
  5. CD30 mp3 problem/question?!?
    By lewisboss777 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 3rd October 2008, 22:46

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •