User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: edt100 water pump (z20net)

  1. #1
    Regular Member mat100edt's Avatar
    Join Date
    Nov 2008
    Location
    south coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default edt100 water pump (z20net)

    has any one changed one of these before?

  2. #2
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ive done a few 2.2 ones but never a 2.0 ...i would say it might be a little swine todo lol ..

  3. #3
    Regular Member mat100edt's Avatar
    Join Date
    Nov 2008
    Location
    south coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    well i already know its internal so thats a kick in the teeth to start with!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil in Water on Z20NET Engine
    By sjanisz in forum Engine & Drivetrain
    Replies: 13
    Last Post: 23rd June 2011, 14:15
  2. Replies: 5
    Last Post: 7th December 2010, 21:48
  3. Water pump?
    By Tigger in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 27th August 2010, 23:00

Visitors found this page by searching for:

vectra z20net water pump leaking

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •