User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Battery Light on

  1. #1
    Regular Member
    Join Date
    Dec 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Battery Light on

    Morning All

    Done some research on this already, so I think I know what you're gonna say, but wanted to explain the problem all the same...

    Driving to work this morning I noticed a bigger than normal turbo lag - I just put it down to a cooler engine or A/C being on etc.

    However, 10 mins later, the battery light came on solid. When I got to work, and shut down, I couldn't get it started again - it's totally dead.

    My instincts are telling me it's an alternator problem? My 1st MOT is due for 1st September, meaning my warranty runs out, and Monday is a bank holiday - I'm hoping I can get it to Vauxhall for a repair under warranty!!

    Any thoughts?

    Cheers
    Maz

  2. #2
    Regular Member slipperysam1984's Avatar
    Join Date
    Apr 2009
    Location
    Bournemouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i would say it was an alternator issue.

    give the stealers a ring tell them your issue. mabey if you book it in today the job could be done under warranty.

  3. #3
    Regular Member parsco's Avatar
    Join Date
    Sep 2008
    Location
    Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I don't think Vauxhall will replace the alternator under warrenty mate. There have been a lot of people on here with the same problem. I had this happen to me just the other day (although I could get it started again because mine's a diesel ) £200 all in from my mates garage up the road

  4. #4
    Regular Member
    Join Date
    Dec 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah - mine's a diesel too...

    Vx were giving me grief about needing to get it in today to order parts and get work on warranty etc - they won't do any repairs on it if I don't book it in before Tuesday, which is kinda hard seeing as it's bank holiday and my car is dead!

    On top of that, eTyres are coming out today to put new tyres on it - so after that, the RAC are coming out to either enable me to drive to garage, or get a tow there.

    What a day - I just can't be bothered getting jib from the Vauxhall garage...

  5. #5
    Regular Member
    Join Date
    Dec 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What a day I am having - I didn't even mention what car I have!!

    It's a 1.9 CDTI SRI 56 Plate

  6. #6
    Regular Member
    Join Date
    Dec 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It was indeed the alternator. Belt was fine, but the voltage coming off the battery was poor.

    I got it to the Vx garage in time, and they are repairing it on warranty

    I had 4 new Nexen tyres put on this morning, and they offered me an MOT for £20 - so here's hoping that doesn't fail!

  7. #7
    Regular Member MightyCris's Avatar
    Join Date
    Aug 2007
    Location
    Constanta, Romania
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Lucky you, mate! I have probably the same problem but for a 2.2 gasoline, does anyone know what type of alternator I need, how much it costs and where can I order it from at a cheaper price?

    Your help is very appreciated!

  8. #8
    Regular Member jonny p's Avatar
    Join Date
    Sep 2006
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    altenator 4 sure replace mine bout 7 months ago an the car only done 31k at the time

  9. #9
    Regular Member jonny p's Avatar
    Join Date
    Sep 2006
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i have 1.9 cdti an mine cost 80 quid off ebay..... exchange

  10. #10
    Regular Member MightyCris's Avatar
    Join Date
    Aug 2007
    Location
    Constanta, Romania
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanx mate, I'll try to repair it first, after I'll see what I'll do

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 18th August 2012, 08:58
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. Battery Light ON - 14.1 volts at battery
    By snapsnap in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 6th December 2011, 13:55
  4. battery light on along with spanner through car light
    By conny in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 24th May 2011, 13:45
  5. Battery light on, 14.4V at the battery!
    By Saulty in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 16th January 2011, 23:29

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •