User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: vectra 3.2 2005 Horn Randomly stops working? Help..

  1. #1
    Regular Member
    Join Date
    Feb 2009
    Location
    asdasd
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default vectra 3.2 2005 Horn Randomly stops working? Help..

    Basically the horn randomly stops working as in you press it and nothing happens..Happened before and i took it to a mechanic and he said that he couldnt find anything wrong with it and he doesnt know why its not working...Then 2 days later Started working agian..
    Today its stopped agian.
    I dont know where to check as i cant even see it in the car..Any Advise? Thanks

  2. #2
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yours was the ex police car wasnt it? If it is, the sirens are sometimes activated by pressing the horn its maybe needing a wiring repair somewhere, when they de-commision them they just pull all the equipment/wiring out.

  3. #3
    Regular Member
    Join Date
    Feb 2009
    Location
    asdasd
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeh ex police car..Weird that it works for about 5 months then randomly stops..How would i fix this? who would i take it to? thanks

  4. #4
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Take it to an auto electrcian buddy, probably a fairly straight forward fix

  5. #5
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It could be something simple but sounds like a job for an auto electrician.

  6. #6
    Regular Member
    Join Date
    Feb 2009
    Location
    asdasd
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    would you know where the actual horn is located..Had a look but cant find it at all lol...I know its gonna be somewhere simple but just cant see it at all.

  7. #7
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    There are two on the inside of the bumper (one at each side). I think you may have to remove the bumper to get to them iirc

  8. #8
    On a Sabbatical
    Join Date
    Jan 2009
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by john.robertson2 View Post
    There are two on the inside of the bumper (one at each side). I think you may have to remove the bumper to get to them iirc
    No need to remove the bumper..

    Neighbours dad had his feel with water and stop working... we just popped the one wheel up on the kerb... then slid under neath and took it off..

    That was a 1.8 engine.

    We looked under mine and noticed I had full plastic protection under neath and would need to remove all that before i could take it out

    Thats a 2.0 DTI engine

  9. #9
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Ah your right enough buddy, had a look at my own

  10. #10
    Regular Member
    Join Date
    Feb 2009
    Location
    asdasd
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    lol Your not going to believe it..But its started working agian..its a miracle...LOL thanks for all your help..TILL NEXT TIME..well next time ill go to a tech and ask him to fix it properly..lol

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 23
    Last Post: 17th November 2012, 23:49
  2. Vectra horn not working
    By Mark Curran in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 9th July 2012, 12:54
  3. Turbo stops working, when ever it likes...? HELP
    By lostdog in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 30th March 2011, 10:55
  4. 2.2 DTi SRi - TURBO STOPS WORKING WHILE DRIVING
    By irmscher-brett in forum Engine & Drivetrain
    Replies: 6
    Last Post: 16th February 2010, 20:29
  5. powersteering stops working
    By kiwiboy in forum Troubleshooting
    Replies: 0
    Last Post: 4th August 2009, 14:28

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •