User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Advice needed plaese

  1. #1
    New Member
    Join Date
    Aug 2009
    Location
    south west scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Advice needed plaese

    I have a 2005 vectra sri 120 cdti with a missfire at 1500rpm,it only happens at part throttle, after 1500rpm the car drives fine.
    I got a new egr valve fitted by a vx dealer about 2 months ago.
    Any ideas would be welcome

  2. #2
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    Could be the third injector, remove the electrical plug and check the condition of the connectors. Kit costs about £15 from Vx can be fitted easy if you can use a soldering iron. Vx charge about £70 to do this job.

  3. #3
    Regular Member
    Join Date
    Aug 2009
    Location
    Havant
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what about the swirly flappy things? can't remember what they are called lol sometimes they get stuck in the open or closed positions causing bad running at high or low rpm depending on where they are stuck.

  4. #4
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I didnt think the 3rd Injector was a problem on the 120 CDTI engine?

    Was it not only on the 150?


    Bye bye Vec B
    - Hello Siggy!

  5. #5
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    Doh, missed the 120 bit, also the Swirl valves are CDTI 150 only.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. hi all advice needed please
    By matt450 in forum General Chat
    Replies: 1
    Last Post: 21st February 2012, 21:22
  2. 3.2 Advice needed
    By Lee_gsi in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 27th July 2011, 22:20
  3. Advice needed........
    By axelf in forum Engine & Drivetrain
    Replies: 3
    Last Post: 19th June 2010, 18:44
  4. could someone plaese do me a photoshop
    By glynn in forum Photoshop section
    Replies: 30
    Last Post: 12th October 2008, 21:10
  5. Advice needed
    By bgm46 in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 26th October 2007, 21:37

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •