User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Problem with Calibra

  1. #1
    Regular Member JSYSH466Y's Avatar
    Join Date
    Dec 2008
    Location
    Newcastle under Lyme
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Problem with Calibra

    My mates got a 2l ECOTEC ina Calibra, runs fine when cold, when warm, no acceleration at all till gets to 4k revs in 1st or second (feels like the engine has flooded), then goes like **** off a shovel.

    So far, this has been done to try and sort it......
    Air Mass sensor replaced
    Crank sensor replaced
    Cam sensor replaced.
    New airbox and filter fitted (to get rid of that induction kit)
    Complete replacement exhaust system fitted
    EGR valve blanked off

    All cylinders working and all plugs are sparking fine.
    Head is holding pressure.

    Any ideas???

  2. #2
    Regular Member mark_647's Avatar
    Join Date
    Jun 2008
    Location
    Wales, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I doubt it but perhaps worth consideration - Throttle Position Sensor ??

    Sorry I cant help more, but good luck !

  3. #3
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Timing may be out hence why is slow at the bottom an poo off a stick up top?

  4. #4
    Regular Member JSYSH466Y's Avatar
    Join Date
    Dec 2008
    Location
    Newcastle under Lyme
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Says the timing may be an option as head gasket changed not long ago. Any other ideas

  5. #5
    Regular Member poves's Avatar
    Join Date
    Dec 2007
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I once had alot of trouble with an astra sri , was the fuel pump.

  6. #6
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Quote Originally Posted by poves View Post
    I once had alot of trouble with an astra sri , was the fuel pump.
    Mechanical or electrical?

  7. #7
    Regular Member JSYSH466Y's Avatar
    Join Date
    Dec 2008
    Location
    Newcastle under Lyme
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    forgot to say he says "thanks"

  8. #8
    Regular Member jonny p's Avatar
    Join Date
    Sep 2006
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    idle air control valve ...... or an air leak on the induction side ....ie the fat hose off the air box

  9. #9
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Quote Originally Posted by JSYSH466Y View Post
    forgot to say he says "thanks"
    Did he get it sorted mate?

  10. #10
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    coolant temp sensor 2

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new vx calibra
    By poacher in forum Quick Photo Album
    Replies: 12
    Last Post: 30th September 2009, 15:34
  2. Anyone know about Calibra 2.0 16v?
    By dennis_signum in forum General Chat
    Replies: 4
    Last Post: 10th September 2009, 07:17
  3. Never Before Seen - CALIBRA CONVERTIBLE
    By Vaux-Man-G in forum General Chat
    Replies: 28
    Last Post: 27th June 2009, 17:53
  4. Calibra V6
    By John-SRi in forum Non Vectra C/Signum Album
    Replies: 14
    Last Post: 19th May 2009, 22:48
  5. WOW - New Calibra.....
    By spoons in forum Vectra C / Signum Car Chat
    Replies: 30
    Last Post: 12th July 2007, 19:53

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •